A CSE Node Fails to Be Discovered During Automatic Deployment Because the Node Is Not Allocated an IP Address

Publication Date:  2012-07-17 Views:  228 Downloads:  0
Issue Description
Related information about the product and version: CSE V100R001C00.
A CSE node fails to be discovered during automatic deployment.

CSE nodes are classified as service nodes, computing nodes, and system data nodes. Services nodes are deployed on the T8000 and system data nodes are deployed on the T3200.
Alarm Information
None
Handling Process
Step 1     Log in to a switch through the serial port. Then run the display current-configuration command to view the IP address of the switch.

                                           Step 2     Run the ifconfig eth0 command on the CSE management node to view the network segment where the eth0 IP address is located.

 

The CSE management node is deployed on the T8000 first blade.

                                          Step 3     Compare the switch IP address with the eth0 IP address. They are found on different network segments.

The built-in deployment tool must be correctly configured to ensure normal communication between the ISM server and CSE nodes.

  Step 4     Allocate a new IP address to the switch. The new IP address of the switch must be on the same network segment as that of the management node allocated by a DHCP server.

The IP address of the management node allocated by a DHCP server is on the private network segment. Therefore, the IP address of the switch must on the private network segment.

1.         Log in to the switch. Then run the ip addressx.x.x.xy.y.y.y command. x.x.x.x indicates the new IP address of the switch and y.y.y.y indicates the new subnet mask of the switch. The subnet mask of the switch must be consistent with that of the ISM server.

2.         Run the quit command.

3.         Run the save command to save configurations.

                                            Step 5     Run the /home/cse/clean.sh script on the CSE node that cannot be discovered. Then click Refresh Node and start automatic deployment. Check whether the CSE node can be discovered during the automatic deployment.

l   If yes, the fault is removed.

l   If no, contact technical support engineers.

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Root Cause
1. Log in to the CSE node by using KVM. Then run the ping command on the Fabric plane (internal). The execution result shows that the network connection between this node and the ISM server is interrupted.
2.  Run the ifconfig eth0 command on the CSE node. The execution result shows that this node is not allocated an IP address.
3. Check the switches, T8000 server, and system data nodes. These devices are properly powered on. Network cables among devices are correctly connected. Status of network port indicators are normal.
During automatic deployment, the CSE node is not allocated an IP address, causing the communication between the CSE node and ISM server abnormal. The node information cannot be reported to the automatic deployment tool. As a result, the node information is not displayed on the interface of the deployment tool.
 
Suggestions
NONE

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