How to Handle the Problems Occurred During the Installation and Deployment of the VSM

Publication Date:  2012-07-19 Views:  189 Downloads:  0
Issue Description

How do I handle the problems occurred during the installation and deployment of the VSM?

Alarm Information
None.
Handling Process

Step 1      For details about the common problems occurred during the installation and deployment of the VSM and the related solutions, see Table 3-6.

Table 1-1 Common problems occurred during the installation and deployment of the VSM and the related solutions

Symptom

Solution

In the Windows OS, the system prompts that a suspended file is already created during the reinstallation of the VSM.

This is because the suspended file is generated during the previous installation. Enter the following command in the address bar and then press Enter:

%tmp%

Query the ClearInstallDiskDir.bat file and delete it.

The system prompts that the port is occupied during the installation. The screen prompts:

The communication port (12212,12213,12214,12215) of the installation framework is used.
Run the "netstat -an" command to query the usage status of the port, or try later.

l  In the Windows OS, query and end the java, msserver, msdaemon, and javaw processes in the task manager.

l  Wait about a minute and try again after the port is released automatically.

In the Windows OS, the failure message of the isql connection is displayed on the database configuration page.

Check whether the environment variable path contains the following path and ensure that the environment variables of other databases are not configured:

C:\Program Files\Microsoft SQL Server\80\Tools\BINN

Choose Start > Program > Microsoft SQL Server > Query Analyzer. On the Connect to SQL Server page that is displayed, set the IP address of the local host as the service name, select the Start SQL Server if it is stopped check box, enter the password of the sa user, and then click OK. Check whether the SQL Server can be normally connected.

The dialog box for selecting the software library path is displayed on the page for configuring database services.

This is because the system cannot find the database installation package. You need to select the directory of the installation disk or the decompressed installation package.

The database sorting mode is displayed as binary on the database configuration page.

l  If the sorting mode is not set to binary during the installation of the database, the installation of the VSM fails. In this case, you need to manually uninstall the database and then reinstall it. For details, see 20.13 How to Manually Uninstall the SQL Server Database.

l  If the sorting mode is set to binary during the installation of the database and the database runs normally, you do not need to reinstall the database during the installation of the VSM.

When you log in to the client of the NMS maintenance tool, the system prompts "Fail to login the local all nodes."

Ensure that the started deployment service is installed in the correct installation disk directory. For example,  C:\HWENGR\engineering in the Windows OS.

Before starting the NMS maintenance tool, check whether the datamodel.data file with the size of less than 1 MB exists in the /engineering/conf/datamodelDB path. If the datamodel.data file does not exist, the current directory is not the installation disk directory for the installation of the VSM.

Other database problems may occur.

View the SQL Server log files to locate the exact faults.

l  The installation log files are stored in the c:\windows\sqlstp.log path.

l  The patch installation log files are stored in the c:\windows\sqlsp.log path.

Step 2     If the preceding solutions do not work, you need to clean up the system and then reinstall the VSM.

Root Cause
None.
Suggestions
None.

END