NVS_BusinessSvr Process Fails to Be Started

Publication Date:  2012-07-23 Views:  80 Downloads:  0
Issue Description

After the NVR server is connected through the SSH client tool, run the command ./nvsctrl status. It is found that the NVS_BusinessSvr process fails to be started.

Alarm Information
None
Handling Process
• The troubleshooting process in the case that the permission to the process is incorrect is as follows:
    1. Connect to the NVR server through the SSH client tool.
    2. Run the cd /hinvs/psm/bin/ command to access the /hinvs/psm/bin directory.
    3. Run the ll NVS_BusinessSvr command to check whether this binary file already has execution permission (the 'x' letter is set) for its owner. if not, run the chmod +x NVS_BusinessSvr command to add the permission to it.
• The troubleshooting process in the case that the process is already started is as follows:
    1. Connect to the NVR server through the SSH client tool.
    2. Run the ps -ef|grep NVS command to check whether the NVS_BusinessSvr process is running. If yes, the process does not need to be started again.
• The troubleshooting process in the case that the configuration file of the process is incorrect is as follows:
    1. Connect to the NVR server through the SSH client tool.
    2. Run cd /hinvs/psm/etc/ to access the /hinvs/psm/etc directory.
    3. Run the ls command to check whether the PSM.conf file exists. If not, copy the PSM.conf file here from the CDROM disk or install package. If yes, check whether this file is configured correctly
Root Cause

• The permission to the process is incorrect.
• The process is already started.
• The configuration file of the process is incorrect.

Suggestions

Generally, a process fails to be started because its configuration file is modified after the process is stopped manually.

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