Routers Cannot Learn the Route after the Vlink is Configured

Publication Date:  2012-07-27 Views:  430 Downloads:  0
Issue Description

Figure 2-3 shows the OSPF Vlink networking.

Figure 2-3  OSPF Vlink networking


# Configure the USG A:

<USGA> system-view
[USGA] interface Vlanif 10
[USGA-Vlanif10] ip address 192.1.1.1 255.255.255.0
[USGA-Vlanif10] quit
[USGA] router id 1.1.1.1
[USGA] ospf
[USGA-ospf-1] area 0
[USGA-ospf-1-area-0.0.0.0] network 192.1.1.0 0.0.0.255 

# Configure the USG B:

<USGB> system-view
[USGB] interface Vlanif 10
[USGB-Vlanif10] ip address 192.1.1.2 255.255.255.0
[USGB-Vlanif10] quit
[USGB] interface Vlanif 11
[USGB-Vlanif11] ip address 193.1.1.2 255.255.255.0
[USGB-Vlanif11] quit
[USGB] router id 2.2.2.2
[USGB] ospf 
[USGB-ospf-1] area 0
[USGB-ospf-1-area-0.0.0.0] network 192.1.1.0 0.0.0.255 
[USGB-ospf-1-area-0.0.0.0] quit
[USGB-ospf-1] area 1
[USGB-ospf-1-area-0.0.0.1] network 193.1.1.0 0.0.0.255 
[USGB-ospf-1-area-0.0.0.1] vlink-peer 3.3.3.3 

# Configure the USG C:

<USGC> system-view
[USGC] interface Vlanif 11
[USGC-Vlanif11] ip address 152.1.1.1 255.255.255.0
[USGC-Vlanif11] quit
[USGC] interface Vlanif 10
[USGC-Vlanif10] ip address 193.1.1.1 255.255.255.0
[USGC-Vlanif10] quit
[USGC] router id 3.3.3.3
[USGC] ospf
[USGC-ospf-1] area 1
[USGC-ospf-1-area-0.0.0.1] network 193.1.1.0 0.0.0.255 
[USGC-ospf-1-area-0.0.0.1] vlink-peer 193.1.1.2 
[USGC-ospf-1-area-0.0.0.1] quit
[USGC-ospf-1] area 2
[USGC–ospf-1-area-0.0.0.2] network 152.1.1.0 0.0.0.255

# Configure the USG D:

<USGD> system-view
[USGD] interface Vlanif 11
[USGD-Vlanif11] ip address 152.1.1.2 255.255.255.0
[USGD-Vlanif11] quit
[USGD] router id 4.4.4.4
[USGD] ospf
[USGD-ospf-1] area 2
[USGD-ospf-1-area-0.0.0.2] network 152.1.1.0 0.0.0.255 
[USGD-ospf-1-area-0.0.0.2] quit

After the configuration, the USG in Area 2 cannot learn the route in Area 0.

Alarm Information
None.
Handling Process
  1. Run the ospf command to enter the OSPF view.
  2. Run the area area-id to enter the OSPF area view.
  3. Run the vlink-peer command to set the router ID of the peer.
  4. Save the configuration.
Root Cause

To locate the fault, follow the procedures described below:

  1. Run the display ospf lsdb command to check the generation of Summary LSA of the route on ABR USG C. The Summary LSA is normal.
  2. Run the display ospf peer to check the neighbor relation. The neighbor relationship between USG A, USG B, and USG C is normal.
  3. Run the ospf command to enter the OSPF view to check the Vlink configuration.

    OSPF prescribes that all the areas must be connected with the backbone area, namely the Area 0. Run the vlink-peer command to set the logical connectivity.

    Check the Vlink configuration to verify if the configuration is incorrect. When specifying the peer of the Vlink, you should specify the router ID of the peer rather than the IP address of the peer interface. Thus, the Vlink neighbor can be set up. Run the display ospf vlink command to check the neighbor state.

The fault occurs in the process of specifying the router ID of the Vlink peer.

Suggestions

When configuring OSPF Vlink, you must specify the Router ID of the Vlink peer and set right Vlink neighbor relationship.

END