Failure for the SoftCo to Register the CFU Service with the IMS

Publication Date:  2015-07-16 Views:  216 Downloads:  0
Issue Description
Based on customer feedback, the IAD can register the CFU service by dialing *57*TN if the IAD is directly registered with the IMS. However, if the IAD is registered on the SoftCo, a phone connected to the IAD fails to register the CFU service by dialing *57*TN.
Handling Process
Step 1 Confirm that the CFU service is implemented on the IMS and ask the on-site personnel to perform the following operations:
  • Capture the network packet about the IAD's success of registering the CFU service when the IAD is directly registered with the IMS.
  • Capture the logs and network packet about the SoftCo's failure of registering the CFU service when the SoftCo is registered with the IMS.
  • Provide the information about the prefix and number of the SoftCo for Huawei technical support engineers.
Step 2 Check the configuration. It is found that the SoftCo's calling number for registering services has the local right to make outgoing calls and the value of callattribute of the prefix *57* is local. Therefore, the configuration problems are ruled out.

Step 3 Compare the two INVITE messages from the two captured packets. It is found that when the SoftCo is registered with the IMS, *57*05967095723%23 in the TO field of the INVITE message is sent out but when the IAD is directly registered with the IMS, *57*05967095661# in the TO field of the INVITE message is sent out. It is found that the SoftCo changes # to %23 and sends the *57*05967095661%23 out. The IMS cannot identify %23 and returns a 487 error, as shown in the following figure.



Step 4 Run the config sip convert23tosharp flag off command to disable changing # to %23 by the SoftCo. The problem is solved.

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Root Cause
The possible cause is that the code of the digit collection end mark is invalid.

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