CFB Service Failure

Publication Date:  2015-04-21 Views:  194 Downloads:  0
Issue Description
Network: SoftCo5816----IAD132----POTS phone

Versions:
 SoftCo5816: V100R003C01SPC600
 IAD132(T): V300R001C07SPC500

The CFB service is enabled for number 3888, and the forwarded-to number is set to 2726. An outer-office user uses number 8000 to make a call to long number 81760888 corresponding to number 3888, and the call is connected. When another outer-office user uses number 8001 to make a call to long number 81760888, the calling party can hear the ringback tone, but the phone whose number is 2726 does not ring.
Handling Process
Step 1 Pick up the phone whose number is 2726, dial *128#, and verify that the local phone number is 2726.

Step 2 Check the IP address of the device with which number 3888 is registered.

Step 3 Use the LMT configuration wizard to view the services enabled for number 3888.

show subscriber dn 3888
It is found that the PBX group line selection service is enabled for number 3888, and number 2982 belongs to the same PBX group as number 3888. Number 3888 is the main number of the PBX group. When there is an incoming call to the phone whose number is 3888 and the phone is busy, the call is automatically forwarded to number 2982. Therefore, the calling party can hear the ringback tone, but the phone whose number is 2726 does not ring.

Step 4 View the SoftCo logs. The following information is displayed:

INVITE sip:041@172.16.1.2:5060;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.16.1.85:5060;branch=z9hG4bK2sqsiw2erl3euvrxtvu3x1xo3
Call-ID: t23eoyi1xruxlolv1uwtr3uxqqiii2ws@172.16.1.85
From: <sip:8000@172.16.1.85;user=phone>;tag=illixure
To: <sip:041@172.16.1.2>//The EID of outer-office number 8000 is 041.
CSeq: 1 INVITE
Contact: <sip:8000@172.16.1.85:5060;user=phone>
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,REGISTER,INFO,PRACK,SUBSCRIBE,NOTIFY,UPDATE,REFER,PUBLISH
Supported: 100rel
Max-Forwards: 70
Content-Length: 254
Content-Type: application/sdp
......
INVITE sip:039@172.16.1.2:5060;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.16.1.85:5060;branch=z9hG4bK2tq3suoq3ut3solivrlisuqv3
Call-ID: wx2youllxx1vsevryq3ir21vilsoourv@172.16.1.85
From: <sip:8001@172.16.1.85;user=phone>;tag=vyi3rssl
To: <sip:039@172.16.1.2>//The EID of outer-office number 8001 is 039.
CSeq: 1 INVITE
Contact: <sip:8001@172.16.1.85:5060;user=phone>
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,REGISTER,INFO,PRACK,SUBSCRIBE,NOTIFY,UPDATE,REFER,PUBLISH
Supported: 100rel
Max-Forwards: 70
Content-Length: 254

Step 5 Run the show subscriber command to view the relationships between EIDs and numbers. It is found that the call is forwarded to number 2982.

GlobalPortNo DomainName TermName Dn   LongDn IfGlobalLongdn SubPBXNo State BindUserNum
------------ ---------- -------- ---- ------ -------------- -------- ----- ----- ------
207          039        039      2982 8643181760982 NO             0        IDLE    NA
208          040        040      2726 8643181760726 NO             0        IDLE    NA
209          041        041      3888 8643181760888 NO             0        IDLE    NA

----End
Root Cause
A service conflict exists, resulting in a CFB service failure.
Suggestions
The PBX group line selection service conflicts with the CFB service. When planning and configuring services, do not configure both services at the same time.

END