two bonded ADSL has large latency on AR

Publication Date:  2016-08-31 Views:  267 Downloads:  0
Issue Description

Customer has 2 AR1200 routers that have 2 x bonded ADSL lines in each connecting to Telecom Provider that are showing high latency when both lines are in a bonded state. If shutdown one ATM interface the latency returns to normal limits and the circuit functions as expected however when the ATM interface is brought back in service the latency returns and the circuit is unusable.

Handling Process

We followed the way described in RFC 2544 to make a test in the lab according to customer’s configuration, and we got a result as below that there are around 21ms larger latency when using two up-links compared to one up-link. And the reason why two up-links have a little more latency is because of packets fragment which is normal. 

One-uplink


Two-uplink


The lentacy above we tested seems normal, then I doubt there are special situations on customer's network. I asked customer to captured the packets and found there are large packets go through the ATM interfaces. In this case, there may have problem when ATM deal with large packets of the fragments. I asked customer to add commands below under dialer interfaces.

ppp mp fragment enable

ppp mp lfi

ppp mp lfi delay-per-frag 20

The problem was fixed, the reason is as following,

The purpose of these commands you added is to enable fragment of MP packets, to make fragment of large packets to small ones. And the usual using scenario is as following:

When large packets go through the link, the time of transfer is longer. It may affect other packets which require faster forwarding like voice packets, cause latency and impact the service. So use the feature above to fragment the large packets, therefore there will not have large packets to be added to the forwarding queue with small packets which don’t need fragment packets together, what solved the issue above.

 

END