No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Why the pppoe-server function doesn't give DNS to the pppo-client

Publication Date:  2012-07-27 Views:  34 Downloads:  0
Issue Description
After you configure the PPPoe-server function on a AR router that has internet access in one interface and the PPPoe-server function in other interface, the pppo-client can establish the session but this one cannot open the internet webpages...................................
Alarm Information
Null
Handling Process
You have to enable under the Virtual-template interface the next command:
ppp ipcp dns X.X.X.X X.X.X.X<-- where the X.X.X.X is the DNS address
This command enables that the pppoe-server function in the router send the DNS information to the pppoe-client.....
Root Cause
Null
Suggestions
You can turn on the debug information:
<Quidway>debug pppoe-server packet
<Quidway>ter mon
<Quidway>ter debug
You should get this message in other to check that the pppoe-server is sending the DNS information:
*0.2297810 Quidway PPP/8/debug2:
  PPP Packet:
      Virtual-Template1:0 Output IPCP(8021) Pkt, Len 26
      State ackrcvd, code ConfAck(02), id 8, len 22
      IP Address(3), len 6, val 01010106
      Primary DNS Server Address(81), len 6, val c82192c1
      Secondary DNS Server Address(83), len 6, val c82192c9
Please check the topology...

END