No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Wrong configuration of snmp write community leaded to some TL1 commands failure

Publication Date:  2012-07-24 Views:  2 Downloads:  0
Issue Description
Customer told us that some TL1 commands were successfully sent to devices and got the right resonses. But some  TL1 commands failed, responded with tasktimeout.
the BMS version is V200R08B02D061SP23.
Alarm Information
; LST-DSLPORTDETAILINFO::DEV=RJ_EHA201,FN=0,SN=15,PN=0:10::;
     7344156  2007-11-23 18:08:22
M   10 COMPLD
      EN=0    ENDESC=Succeeded.
;MOD-ADSLPORT::DEV=RJ_EHA201,FN=0,SN=15,PN=0:11::LPROFID=
VELC500GDMT_ADCE,ALIAS=RJO 5000004;
      7344156  2007-11-23 18:13:28
M   11  COMPLD
      EN=2686058508    ENDESC=Task timeout
;
Handling Process
Change the snmp read community and write community both on BMS and devices to the same, then the problem disappeared.
Root Cause
By checking the snmp community on the BMS and on the device, we found that the read community is the same, but the write community is different. 
Because of this, when the TL1 sends a command such as LST-DSLPORTDETAILINFO to the device, which only needs read  information from devices,  the device will compare its read community with that on the server, if the device find their read community is the same, it will respond to the BMS server successfully. If TL1 sends a command such as MOD-ADSLPORT, which need both read and write information to the device, so if the device find their write community is not the same, of course it will refuse the write operation and give no response to the server.
Suggestions
When we use TL1  NBI send commands to the devices, if it reponds timeout, first we should check the network, then we should check if the snmp community on both server and device is the same.

END