No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

No Receive Data on the Tester Four Hours After Incorrect Settings of the Tester in the VPN Test of the MA5600T

Publication Date:  2012-07-25 Views:  37 Downloads:  0
Issue Description
Networking: See the attachment
Networking description: The tester is SunSet MTT (BASE VER. S6.10p, MODU VER. S6.01k). On the MA5600T (version: V800R005C32B056), different service VLANs are set for two testers respectively. The 7450 transparently transmits the VLAN. The data of the two VLANs is exchanged on the 7750 to provide the VPN service. The 7750 has two layer 3 interfaces of this service VLAN. The IP address of the 7750 is the gateway of the tester.
Test procedure:
1. Set the IP address and the gateway for the tester. The gateway is the layer 3 VLAN interface of the 7750.
2. The tester sends the APP request to the 7750 and obtains the MAC address of the layer 3 interface on the 7750.
3. Each tester pings the IP address of its peer tester.
4. Start the test (the MAC address obtained by ARP and the IP address in the ping settings are used to fill the specified field of the Ethernet packet) and set the bandwidth of the tester to 100 M.
Test result: When the test starts, the tester panel displays the message "NO ERRORS." Four hours later, the tester panel displays the message "NO RX DATA" but the transmission (TX) is normal. 

 
Alarm Information
Four hours after the test starts, the tester panel displays the message "NO ERRORS." 
Handling Process
1. Use the tester to perform a back-to-back test. Four hours later, the test result is normal. This indicates that the problem is not caused by the tester.
2. Because the MA5600T and the 7450 only transparently transmit the VLAN in the test, checking only their MAC address entries is enough. The check shows that the MAC address entries of the MA5600T and the 7450 persist four hours later.
3. Check the traffic of the uplink port on the MA5600T. Only the upstream direction has traffic and the traffic in the downstream is close to zero.
4. Further check the traffic of the uplink port on the 7450 and the circumstance is the same as that on the MA5600T.
5. Monitor the traffic of the layer 3 interface on the 7750 and find that the layer 3 interface has the RX data but the exchanged data between the two layer 3 interfaces is discarded. Thus, the problem locates on the 7750. The analysis through packet capturing is required to find out the detailed cause.
6. Perform the mirroring packet capturing on the OT925 and find that the 7750 sends the ARP request message to the SunSet four hours later but gets no response. Then, the problem of no RX data occurs. In addition, it is found that the default aging time of the 7750 is four hours. After the aging time of the 7750 is modified to 12 hours, the problem of no RX data reoccurs in the test 12 hours later.
In the test in another area, however, the problem of no RX data does not occur. Use the method (IP THROUGHPUT mode) used in this area to capture packets and find that the tester sends an ARP request to the 7750 every three minutes. After the confirmation, based on the ARP request, the 7750 updates its corresponding ARP entry. In this way, this ARP entry of the 7750 is updated every three minutes and does not reach the aging time.
8. In the layer 3 test in the area where the problem occurs, the BERT/THROUGHPUT mode is used. This mode is a common test mode and applies to the layer 2 test. In this mode, no ARP request is sent while the ARP request message can be responded. As a result, four hours later, the ARP entry of the 7750 is aged, the packet to be forwarded is discarded, and the tester cannot receive any data.
9. In the layer 3 throughput test, the SunSet MTT uses the IP THROUGHPUT mode of the IP feature for test. The results of all tests are normal and the problem is solved. 
 
Root Cause
The possible causes for failing to receive the data on the tester are as follows:
1. The settings of the tester cause the timed settings to be enabled in the IP throughput test.
2. The ARP entry or MAC address entry on the MA5600T is abnormally aged four hours later and the forwarded packet is discarded.
3. The ARP entry or MAC address entry on the 7750 or 7450 is abnormally aged four hours later and the forwarded packet is discarded. 
 
Suggestions
1. When you use the SunSet for the 100M throughput test, the version should be: BASE VER. S6.10p and MODU VER. S6.01k.
2. In the layer 3 throughput test, the SunSet MTT should use the IP THROUGHPUT mode of the IP feature for test to ensure that the test can be performed. 

 

END