No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

The License Statistics Tool Cannot Be Connected to the Database of the Dual-Node NMS

Publication Date:  2012-07-25 Views:  47 Downloads:  0
Issue Description
When the License Server is deployed, the license information used by the current network needs to be collected through the license statistics tool. Currently, the license statistics tool only has the Windows version. Engineers attempt to connect the license statistics tool to the database of the NMS. The following alarm information is displayed: 
Alarm Information
Fail to obtain the equipment list information from the database; please check whether the basic NMS configurations are correct or whether the network is normal.  
Handling Process
Modify the IP address corresponding to the sybase 4100 port number on the active Server to the actually used IP address, and restart the database. Now, the license statistics tool can be connected to the database properly.  
Root Cause
Currently, the license statistics tool only has the Windows version. The PC where the license statistics tool is installed must be configured with an IP address that is in the same network segment as the IP address of the network adapter of the connected NMS. Only in this way can the license statistics tool be connected to the Solaris system.
For the dual-node NMS, the default port number and IP address of the sybase is 4100 and 127.0.0.1 respectively. Obviously, the license statistics tool cannot be connected to the database of the NMS. The tool is designed to function well when it is connected to a database.
Therefore, modify the IP address corresponding to the sybase 4100 port number on the active Server to the actually used IP address, that is, the IP address of the network adapter that is used for connecting the PC to the Server. 
 
Suggestions
After the IP address corresponding to the sybase 4100 port number on the active Server is modified to the actually used IP address rather than the original 127.0.0.1, there exists a huge risk. After active/standby switchover occurs, the standby Server cannot be connected successfully. In the dual-node environment, the IP address of 127.0.0.1 is required.
After using the license statistics tool, be sure to modify the corresponding IP address to the original 127.0.0.1. 
 

END