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Metro1000V3 after upgrade the EFS or EFSC keeps the old version

Publication Date:  2012-07-25 Views:  36 Downloads:  0
Issue Description
(1) Use Toolkit to upgrade Metro1000V3 from 5.37.02.22 to 5.37.04.12P01, the EFS/EFSC upgrade from 2.21 to 2.42 according to the version math table.
(2) Upgrade success, but check the system’s board information then find there has some problem; the system had upgrade to 5.37.04.12P01 but EFS/EFSC keeps the old version 2.21.
(3) Cold-reset the EFS/EFSC, after board bring up check the version again, still the same.
(4) Download the EFS/EFSC software by Navigator, then active again, still the same. 
Alarm Information
NONE
Handling Process
(1) Use command ": ethn-debug-enable: enable” to enable the debug command.
(2) Use command ": ethn-debug: bid, “test remove ofs2\hwx\ne.ini” and command “: ethn-debug: bid, “test remove ofs2\hwx\42efs10.bld” to delete the software in NSF2.
(3) Use command”: cfg-reset-board: bid, hard” to cold-reset the EFS/EFSC.
(4) Use command”: cfg-get-bdverinfo: bid” to check the EFS/EFSC version after board bring up.
(5) Use command”: ethn-debug-enable: disable” to disable the debug command.
(6) Finished.
Root Cause
(1) Use toolkit upgrade the system, toolkit only download the software to OFS1, we collect the data from system, the result shows that that the OFS1 have the new version software which is 2.42 but the OFS2 also have the software which is 2.21 the old version.
(2) The root cause is EFS/EFSC board working at OFS2 which is old version, so check the board’s version is 2.21.
(3) There have three feasibility will cause software working at OFS2.
A: Use command to force the working software to OFS, EFS/EFSC no support this function can choose the OFS1 or OFS2 for working software so exclude this feasibility.
B: When EFS/EFSC bring up, the NSF1 can not bring up normally so bring up OFS2. Do the testing in the lab, EFS/EFSC can bring up normally, so exclude this feasibility.
C: Before upgrade, EFS/EFSC working at OFS2, after upgrades still working at OFS2. 
So, the root cause is the third feasibility.
Suggestions
(1) How to know the working software is OFS1 or OFS2?
The network can no check the working software, need feed back to H&Q use special tool to check.
(2) If delete the software will affect the service?
Delete the software, software will reset, during this time, service will affect, this operation will no affect the system. 
(3) Before the operation, please prepare the spare board.

END