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Mutual Exclusion Between the MA5600 Process and the MA5606 Process Because of Insufficient Licenses of the N2000 BMS Server

Publication Date:  2012-07-25 Views:  45 Downloads:  0
Issue Description
The N2000 BMS server computer is configured with the Dell server and Windows OS. The memory capacity is 4 GB and the disk capacity is 120 GB. The BMS version is V200R008B02D061SP25. After an MA5600 node is created, it can be added to the N2000 BMS. But when you double-click the node, nothing is displayed. The boards and ports of the MA5600 cannot be displayed normally. If you close the MA5605 process of the N2000 BMS, the boards and ports of the MA5600 are displayed normally. 
Alarm Information

Earlier phase: null
Later phase: insufficient NE licenses 
 

Handling Process
1. Check the configuration of the faulty node on the N2000 BMS. No error is detected. The faulty node is configured the same as other nodes that work normally.
2. The version of the faulty node is V300R002B02D105. It is confirmed that the version of the node matches the version of the N2000 BMS.
3. Check the N2000 BMS database and logs, and it is found usages of the database and log space on the N2000 BMS are 30% and 40% respectively. The problem is not caused by the usage.
4. The problem persists after the daemon process of the MA5600 on the N2000 BMS is restarted.
5. Check the resource usage on the N2000 BMS server. The memory usage reaches 2.6 GB. It is not sure that the problem is caused by the memory usage.
6. Require the customer to expand the capacity of the server (adding a 1 GB memory bar). The problem persists after a test for a long time. The panel and ports of the MA5600 cannot be displayed.
7. Once the customer reported that an alarm is generated on the N2000 BMS indicating insufficient NE licenses. After a new license is applied and imported into the N2000 BMS server and the MA5600 is refreshed, it is found that the panel and ports of the MA5600 are displayed normally. At the same time, the MA5605 process runs normally.
8. The problem does not reoccur after a long time of observation and tests. The problem is solved. 
 
Root Cause
The problem can be traced to the following causes:
1. The data configuration is incorrect of the N2000 BMS on the device side.
2. The N2000 BMS version and the device version do not match.
3. The database and log space of the N2000 BMS server overflow.
4. The process of the N2000 BMS server is deadlocked or hardware resources of the system are insufficient.
5. Licenses of the N2000 BMS are insufficient. 
 
Suggestions
When an NE fails to be displayed on the N2000 BMS, you can trace the problem to the following causes:
1. Data configuration is incorrect of the N2000 BMS on the device side.
2. The N2000 BMS version does not match the device version.
3. The database and log space on the N2000 BMS server overflow.
4. The process of the N2000 BMS server is deadlocked or hardware resources of the system are insufficient.
5. The licenses of the N2000 BMS server are insufficient.
In the versions earlier than the N2000 BMS R9, each NE license can support 60 device ports. When a device, such as the MA5600 (with n lines), is added to the N2000 BMS, the number of required licenses is (n/60) + 1. Hence, the number of available licenses must be larger than (n/60) + 1. When the number of available licenses is smaller than (n/60) + 1, the N2000 BMS generates an alarm indicating insufficient licenses. If the number of available licenses is a little larger than (n/60) + 1, such as (n/60) + m (m is a small value), the N2000 BMS does not generate alarms. But the N2000 BMS may produce strange problems, such as mutual exclusion of processes described in this case. 
 

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