No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

FAQ-How to Rectify Error 1024 in the Sybase Logs

Publication Date:  2012-07-25 Views:  8 Downloads:  0
Issue Description
Q:
How to rectify error 1024 in the Sybase logs? 
 
Alarm Information
SQL Server has run out of LOCKS. Re-run your command when there are fewer active users, or contact a user with System Administrator (SA) role to reconfigure SQL Server with more LOCKS. 

 
Handling Process
A:
Error 1024 is displayed as follows:
SQL Server has run out of LOCKS. Re-run your command when there are fewer active users, or contact a user with System Administrator (SA) role to reconfigure SQL Server with more LOCKS.
When the ASE is running, the preceding error is displayed if the number of locks is not enough. The number of locks is related to the configuration parameter number of locks of the ASE. The default value of the parameter number of locks is 5000. The value ranges from 1000 to 2147483647. To solve the problem, the number of alarms needs to be increased. Each lock structure occupies a memory of 120 Bytes. In versions later than ASE 12.5, the memory is allocated dynamically. Hence, opening each lock request occupies a memory of 120 Bytes.
You can increase the number of locks with the following two methods:
1. Directly modify the parameter number of locks in the servername.cfg and restart the Sybase. 2. Run the isql command to log in to the database and dynamically modify the value of the parameter:
1) To obtain the existing configuration value, run the following commands:
1> sp_configure “number of locks"
2> go
2) To modify the number of alarms to a larger value, run the following commands:
1> sp_configure “number of locks”, new_value
2> go 
 
Root Cause
Null
Suggestions
Null

END