No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Egress direction of LPU Micro Engine works invalidly lead to packet lose

Publication Date:  2012-07-27 Views:  33 Downloads:  0
Issue Description
Some of TSTT Internet and Enterprise Customers connected to San Juan S8512 Switch (using layer 2 vpls circuits) began complaining to TSTT about extremely slow internet and layer 2 vpls services. 
Topology
San Juan S8512----San Juan NE40E----San Juan NE80E----Augustine NE40E----Augustine S8512
Alarm Information
[STAUGUSTINE_S8512_MCN_N1]ping -s 1000 -c 20 10.80.3.50
  PING 10.80.3.50: 1000  data bytes, press CTRL_C to break
    Reply from 10.80.3.50: bytes=1000 Sequence=1 ttl=252 time=1 ms
    Request time out
    Reply from 10.80.3.50: bytes=1000 Sequence=3 ttl=252 time=1 ms
    Reply from 10.80.3.50: bytes=1000 Sequence=4 ttl=252 time=1 ms
    Request time out
    Request time out
    Request time out
    Request time out
    Request time out
    Reply from 10.80.3.50: bytes=1000 Sequence=10 ttl=252 time=1 ms
    wrong data byte #514 should be 0xfa but was 0x2
    Request time out
    Reply from 10.80.3.50: bytes=1000 Sequence=12 ttl=252 time=1 ms
    wrong data byte #514 should be 0xfa but was 0x2
    Reply from 10.80.3.50: bytes=1000 Sequence=13 ttl=252 time=1 ms
    Request time out
    Reply from 10.80.3.50: bytes=1000 Sequence=15 ttl=252 time=1 ms
    Request time out
    Request time out
    Request time out
    Reply from 10.80.3.50: bytes=1000 Sequence=19 ttl=252 time=1 ms
    wrong data byte #514 should be 0xfa but was 0x2
    Reply from 10.80.3.50: bytes=1000 Sequence=20 ttl=252 time=1 ms
  --- 10.80.3.50 ping statistics ---
    20 packet(s) transmitted
    9 packet(s) received
    55.00% packet loss
    round-trip min/avg/max = 1/1/1 ms 
Handling Process
Step 1:  From St. Augustine S8512 ping San Juan S8512 loopback address.The ping test is ok if packet less than 188 bytes.Once the packet size increased beyond 188 bytes packet loss was experienced.
Step 2:  Traced Route to determine the path of the ping packets from St. Augustine S8512 to San Juan S8512 loopback address:
[STAUGUSTINE_S8512_MCN_N1]tracert 10.80.0.18
 traceroute to  10.80.0.18(10.80.0.18) 30 hops max,40 bytes packet
 1 10.80.3.41 11 ms  10 ms  9 ms 
 2 10.80.2.77 20 ms  2 ms  10 ms 
 3 10.80.2.62 18 ms  2 ms  19 ms 
 4 10.80.3.50 19 ms  4 ms  18 ms
Step 3:  Performed ping tests from St Augustine S8512 to the various next hop addresses along the path to San Juan S8512 to determine where packet of sizes greater than 189 bytes were being dropped.And the packet lose is occurred when we ping 20 10.80.3.50.
These tests indicate that a problem resides between the San Juan NE40 Router and S8512 Switch
Step 4:  Performed ping tests from St Augustine S8512 to another vlan interface (vlanif 7)  ip address  configured and trunked on the San Juan S8512 uplink to San Juan NE40E.The result is ok.
The 10.80.222.50 belongs to a layer 3 vpn (voice_vpn) that is accessed from both St. Augustine and San Juan S8512 Switches. It was surprising to see the successful pings since the same link was successfully utilized between San Juan NE40E Router and S8512 Switch that was used for the failed ping attemps in STEP 3.
Step 5:  Performed ping tests from San Juan NE40E to the San Juan S8512 vlanif 2 ip address.The result is ok.
Step 6:  Performed ping tests from San Juan NE80E to the San Juan S8512 vlanif 2 ip address. Packet lose appear.
Step 7:  Restart egress direction of LPU Micro Engine  
After finish the test of step 3-6,we think that G2/0/0 of San Juan NE40E is the fault point.And R&D give us a suggestion that it is maybe caused by egress direction of Micro Engine which belongs to LPU2 works invalidly.And this type problem has occurred at other site and caused the same problem.After restart egress of Micro Engine,this problem be resolved. The solutsion is:
<Quidway>sys
   [Quidway]_d
   [Quidway_d]efu me slot 2 egress restart all-me
Root Cause
R&D engineer of NE40E log in router to diagnose this problem and find that it is caused by egress direction of Micro Engine which belongs to LPU2 works invalidly.And this type problem has occurred at other site and caused the same problem of packet lose.After restart egress of Micro Engine,this problem be resolved. The solutsion is:
<Quidway>sys
   [Quidway]_d
   [Quidway_d]efu me slot 2 egress restart all-me    
Suggestions
No

END