No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Incorrectly Setting the RTP Ephemeral Termination Range on the Z Softswitch Causes the MA5616 Users to Hear the Busy Tone After Random Offhook and Dialing

Publication Date:  2012-07-25 Views:  56 Downloads:  0
Issue Description
Topology
Z softswitch�bearer network�MA5680T�MA5616
MA5616 version: MA5616 V800R306C01B053
The MA5616 users hear the busy tone after offhook and dialing at a random time.
Alarm Information
Null
Handling Process
1. When the fault recurs, ping the Z softswitch from the MA5616. No packet loss occurs and the H.248 interface is normal.
2. When the fault recurs, trace signaling on the MA5616. It is found that the softswitch directly responds with the busy tone after the user picks up the phone and dials a number.
3. Trace signaling on the Z softswitch.
msg  to  mgc: MEGACO/1 [10.67.5.53]:2944 
P=161486837{C=4{A=A161,A=A100000064{M{ST=1{O{MO=RC,nt/jit=40},L{v=0 c=IN IP4 10.68.75.10 m=audio 28656 RTP/AVP 8 a=ptime:20 }}}}}}
msg from mgc to mg: MEGACO /1 [10.67.41.126]:2944 
T=161486838{ C=4{ MF=A161{ SG{ cg/bt}}}}
In the ADD reply message reported by the MA5616, the ID allocated to the RTP ephemeral termination is A100000064. According to the normal flow, the softswitch should play the ringing tone to the called party, and at the same time respond with the Modify command to the voip user, the command containing the ringing tone message (al/ri). The Z softswitch, however, responds with the busy tone message (cg/bt). On the Z softswitch, the RTP ephemeral termination ID must be specified manually. Therefore, it is suspected that the RTP ephemeral termination range is not correctly set. Check the RTP ephemeral termination range set on the Z softswitch. It is found that the range is set to A100000000-A100000032. When the ephemeral termination ID allocated by the MA5616 to the user is A100000064, it exceeds the RTP ephemeral termination range set on the Z softswitch. The Z softswitch cannot identify the termination ID and thus plays the busy tone.
4. Set the maximum number of the RTP terminations on the MG interface of the MA5616 to 32.
MA5616_1(config-if-h248-1456)#mg-software parameter 24 32
Reset the MG interface. Test the service. Now, the service is normal.
Root Cause
1. The L2 network is faulty.
2. The interconnection with the Z softswitch is improper.
Suggestions
1. By default, the RTP ephemeral termination range of the MA5616 V800R306C01B053 is A100000000-A100000064.
2. When the MA5616 is interconnected with the Z softswitch, the RTP ephemeral termination range on the Z softswitch must be the same as that on the MA5616.
3. The RTP ephemeral termination range of the MA5616 can be modified through software parameter 24 of the MG interface. The modification takes effect after the MG interface is reset.

END