No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Installation Scripts can not be running due to the System Environment Variables Missing

Publication Date:  2012-07-25 Views:  48 Downloads:  0
Issue Description
During the U2000 Installation, after click the install.bat, one Dos Window appeared and disappeared quickly. After that, nothing happened. 
In field try to execute the install.bat in the Dos Windows, it just show a blank line and stopped (refer the attachment install.JPG).  If we opened the install.bat and modify the first line from @echo off to @echo on and execute this file in the Dos Windows, it will show:
echo "c:\" | findstr [;!] > nul 2>&1
Then, all stopped. Installation can not continue. 
Operation System: Windows 2003
U2000 Version: V100R002C01SPC002
Alarm Information
NULL
Handling Process
Add the %SystemRoot%\system32 in the system enviroment variables and run the install.bat. Everything is all right. 
Root Cause
Because field was successfully installed a new U2000 in anther computer, after we checked both computer and find the problem should be in command "findstr".
If we execute the findstr in the computer which has installed U2000, it will show :
FINDSTR: Bad command line.
But if we execute the findstr in the problem computer, it will show:
'findstr' is not recognized as an internal or external command,
operable program or batch file.
So, it should be the findstr missing in the problem computer. From the analysis, the findstr should be the system program. 
Finally, we found it locates in windows\system32\ folder. 
Again, we found the problem system has not system environment variables %SystemRoot%\system32. 
Suggestions
Need the installation guide to check the system environment variables if the script used the programes. 

END