No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

BMS Client login issue in MTNL BB due to wrong configuration in MPLS Network

Publication Date:  2012-07-25 Views:  25 Downloads:  0
Issue Description
The MTNL BB network consist of following elements:
BMS Server------->layer-2 Switch----->PE router(NE80)-------> Tier-1(NE80E)------>Ring of 4 Tier-2's------>DSLAM's------>Client.
The BMS Client login was not happening leaving some clients eg.(26 clients out of 35 clients).
Alarm Information
Null
Handling Process
As Some of client login was happening and some of not  so we have done troubleshooting as follows:
1) Firstly we checked applications at server level as it was ok so we checked reachability of the clients and DSLAM's from Server.
2) The Client and DSLAM's IP were not reachable from server but reverse reachability from client and DSLAM's towards Server was OK.
3) So we checked reachability of Client and DSLAM's from PE router through the vpn used for connectivity of BMS from where it was not ok.
4) So we did traceroute for same from server and PE router which was giving proper reachability.
5) We started trace from DSLAM and Tier-2 also which after coming to PE router was taking some different path which was pointing towards some different VPN IP.
6) So we checked the routing at PE router where we found one static route configured for directly connected Server network using some different VPN.
The configuration on PE router was as follows:
interface Ethernet 9/1/X
description TO_BB_ServerNOC              
undo shutdown
ip binding vpn-instance bb-ems   ------->VPN for BMS server
ip address 10.128.0.1 255.255.255.0
ip route-static vpn-instance MU-securevpn 10.128.0.0 255.255.255.0 10.190.1.253
So after removing the route problem resolved and client login was ok.
Root Cause
After checking the problem at server level we checked it at next level i.e.at PE router where we got that problem is at PE router.
Due to configuration of one static route at PE router which was configured using diifferent vpn for directly connected network pointing towards some different IP as next hop.
Because of this route the server was not getting proper path to reach the DSLAM and client's Network.
Suggestions
There is no need to configure any static route for the network which comes under same IP pool.

END