No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

ATS data configuration problems led to a global format for the local number is displayed

Publication Date:  2012-08-06 Views:  48 Downloads:  0
Issue Description
When there is a call between two IMS subscribers, callee number on the caller terminal should display cornet format (without country code and area code), but the results show the global format. 
IMS version: IMS8.1 
ATS version is: V100R003C01SPC100.
Alarm Information
None
Handling Process
1, first check DSPCFG command on the ATS, results are as follows:
+++    ATS/*MEID:51*/        2011-03-19 12:35:21+02:00
O&M    #2454
%%LST DSPCFG: USERTYPE=NORMAL;%%
RETCODE = 0  Operation succeeded
The result is as follows:
-------------------------
                         Display index  =  65534
                     Display user Type  =  NORMAL
                          Input header  =  PAI Only
           Output international format  =  a global international standard number without the minus sign
                    Output toll format  =  a toll number with the toll prefix
                   Output local format  =  local
                  Output mobile format  =  a mobile number without the toll prefix
     Output home NPA local call format  =  NULL
  Output foreign NPA local call format  =  NULL
Output home NPA local toll call format  =  NULL
                    Output number type  =  TEL format
                         Output header  =  PAI header
                   Output display name  =  no change the display name
(Number of results = 1)
---    END.
2, seen from the data configured to display the output format for the tel number format, and Input header  =  PAI Only, and display the local number for local call, that is, without the country code and area code.
3, from the message (attachment) can be seen, the terminal will be sent to the called side of the PAI header field with two, two PAI header fields as follows:
P-Asserted-Identity: "Anonymous" <sip:+864713279999@nmg.ctcims.cn;cpc=ordinary>
P-Asserted-Identity: "Anonymous" <tel:3279999;cpc=ordinary;phone-context=+86471>.
4, the tracking information found two PAI headers, sip PAI format is the previous, tel PAI format in the post, because when the display will show the first PAI, so caller ID is +864713279999.
5, upon inquiry, found soft parameter control the order, so we modify the soft parameter 3044 to 1, local calls appear normal.
3044 introduced the soft parameters: P3044-SP_TELURI_FIRST_IN_PAI
The default value of 0
Usage of a detailed description of the soft parameters
To control the sequence of PAI when there are both tel PAI and SIP PAI in a INVITE message.
Default value = 0
 = 0: If you receive the PAI header field is the SIP URI in the first ,second is the TEL URI, then send a message to keep the order intact.
= 1: If you receive the PAI header field is the SIP URI in the first, second is the TEL URI, then send a message to adjust the order.
6, execute the command MOD SFP: SPID = 3044, VAL = 1; appear normal.
Root Cause
1, Data configurations problem on ATS.
2, ATS software parameter control.
Suggestions
None

END