No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

U2000 HA switching failed due to VCS error

Publication Date:  2012-07-25 Views:  32 Downloads:  0
Issue Description
1. The U2000 HA system switched to the backup server  due to DCN failure  some time ago, then dual-host was formed.
2. After DCN restored, the Secmaster was forced to be the active server through maintenance suite.
3. When data synchronization completed, we tried to switch the active server back to Primaster according to the customer's requirement, but it failed, the error message was:VCS ERROR V-16-1-50822.
Alarm Information
VCS ERROR V-16-1-50822, Cluster SecmasterCluster, of which system Secmaster is a member, is not available.
Handling Process
1. The system status was normal after checking VCS gui interface.
2. The communication was normal by ping.
3. Data was synchronized by using this command:vradmin -g datadg repstatus datarvg.
4. The resource was not forzen or faulty.
5. But the "Remote Cluster Status" was in initing status, this meant that the VCS status became abnomal.
6. The following commands were used to fix VCS:
    a. This command was used to check the VCS process: ps -ef | grep had.
    b. This command was used to repair the VCS: hasys -force Primaster.
    c. Tried to restart the VCS on both Primaster and Secmaster servers: first offline AppService on Primaster, then stop VCS: hastop -all -force, and then start VCS: hastart -onenode.
After repairing and restarting the VCS process, the HA system bacame normal.
    
Root Cause
1. The system was in dual-host or revertive state.
2. The communication was interrupted.
3. Data was not synchronized.
4. The resource was in frozen or fault state.
5. In case of the network instability ,VCS state became abnomal.
Suggestions
In case of the network instability ,VCS state became abnomal, then we should try to repair and restart the VCS process.

END