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ATS released the call before session timer expires

Publication Date:  2012-08-06 Views:  37 Downloads:  0
Issue Description
The IMS version is 8.1 and the IMS call initiated session timer. From ATS’ interface tracing file we can known the session timer is 180 seconds when the call set up, and this call will be refreshed by UAC.



But after approximately 150 seconds ATS released the call, not until 180 seconds.



Alarm Information
Null
Handling Process
When looking into the RFC4028 we find this is not a problem, ATS is release the call according to the RFC4028 description:
Similarly, if the side not performing refreshes does not receive a
session refresh request before the session expiration, it SHOULD send
a BYE to terminate the session, slightly before the session
expiration. The minimum of 32 seconds and one third of the session
interval is RECOMMENDED.

So, in this case, the release timer is 180 – MIN(32, 180/3) = 180 – 32 = 148 seconds if ATS have not received the re-INVITE from UAC. This is matches the testing result, ATS released the call after 148 seconds. So, this is not a problem.
Root Cause
This call is the basic IMS call without any other service, so this problem should be the ATS' timer issue.
Suggestions
RFC4028 is description about session timers in SIP, if there are questions about session timer it better to read it first, may be you can get the answers from it.

END