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Subscriber experience poor performance cause Car bug for speed limit in same slot

Publication Date:  2012-07-27 Views:  35 Downloads:  0
Issue Description
Version: NE40E V300R003C02B697 ,no patch.
Networking overview as below:
Before Cutover: CE router->PE1(NE40E-A slot2) UNI->PE1(NE40E-A slot1) NNI->PE2(NE40E-B)->CIX(internet exchange gateway).
After Cutover:CE router->PE1(NE40E-A slot2) UNI->PE1(NE40E-A slot2) NNI->CIX(internet exchange gateway).
The key configuration as below:
Before Cutover:
UNI:
#
interface GigabitEthernet2/0/23
 description Enterprise Internet - to CE Nusuara Kubu Ema
 undo shutdown
 ip binding vpn-instance VPN_internet
 ip address 10.200.149.1 255.255.255.252
 qos car cir 5000 pir 5000 cbs 500000 pbs 500000 green pass yellow pass red discard inbound
 qos car cir 5000 pir 5000 cbs 500000 pbs 500000 green pass yellow pass red discard outbound
#
NNI:
#
interface GigabitEthernet1/0/0.1007
 vlan-type dot1q 1007
 description connect NE40E KPG via Cisco UNIP PDGPE1
 ip address 10.159.200.26 255.255.255.252
 ospf authentication-mode md5 1 cipher +*aWK<U3PRS$Q00K+VRa[Q!!
 mpls
 mpls ldp
 statistic enable
#
UNI and NNI locate in Slot2 and Slot1  respectively.
After Cutover:
UNI:

#
interface GigabitEthernet2/0/23
 description Enterprise Internet - to CE Nusuara Kubu Ema
 undo shutdown
 ip binding vpn-instance VPN_internet
 ip address 10.200.149.1 255.255.255.252
 qos car cir 5000 pir 5000 cbs 500000 pbs 500000 green pass yellow pass red discard inbound
 qos car cir 5000 pir 5000 cbs 500000 pbs 500000 green pass yellow pass red discard outbound
#
NNI:
#
interface GigabitEthernet2/0/0
 description Enterprise Internet - to Cisco C7206(CIX)
 undo shutdown
 ip binding vpn-instance VPN_internet
 ip address 10.200.149.5 255.255.255.252
#
UNI and NNI locate in Slot2 only.

fault phenomena:

Subscriber feedback that only get less then1Ms bandwidth.





Alarm Information
Null
Handling Process
1.During the cutover period,no hardware change happen.Exclude suspicion of hardware issue.
2.Check the VPN routing table is normal,the service is still fine but only speed limit is not match.Exclude suspicion of Routing issue.
3.Check the FIB table is normal,the service is still fine but only speed limit is not match.Exclude suspicion of data process issue.
4.Remove QOS policy and retest the speed,the result is normal. Compare the difference configuration of Before Cutover and After Cutover.Easy to  find out Car QOS policy  under VPN-instance view will invalidation when data forwarding in same slot.Even will change  the speed limit to very low speed. Report to R&D for help,the suggestion is to upgrade the version to V6R1C00SPC800 to resolve the issue due to current version is old and is not recommended version already.

Root Cause
1. Hardware issue
2. Routing issue
3. Data process issue
4. Version issue related to QOS
Suggestions
Null

END