No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

VOIP & IMS Services Stopped in ME60 after temporary cut-off of suscribers that are using L3 DHCP

Publication Date:  2012-07-27 Views:  79 Downloads:  0
Issue Description
Thousands of suscribers lost VOIP and IMS Service after Customer did one operation on BRAS by cutting temporary the suscribers (aaa cut access users ), after that, most of suscribers cannot get the service.

The toplogy is like this:

Suscriber -----> DSLAM -----> Switches (Metro-IP)-----> BRAS (ME60) ------> BACKBONE MPLS ----> VoIP / IMS Plateform

The VoIP and IMS Service Sucribers use The BRAS (ME60 or MA5200G) as a L3 DHCP server to allocate ip-address to suscribers.


Alarm Information
Null

Handling Process
Null

Root Cause
In fact, the VOIP and IMS suscribers use L3 DHCP to get IP from BRAS, but in the morning after operation, the suscribers cannot get the service,

the root cause is that the profil of that suscribers is Off-line, and the suscribers still use the old ip they get before, and they don't know that they are off-line of BRAS,

In fact, in L3 DHCP , after a suscriber get an IP using a DHCP Request, he continue using it until the timer: dhcp_lease_time is finished, and there is no mechanism in DHCP to detect that the BRAS cut temporary the service ( it not like ppp who have keep_live messages)

Also the default value of HUAWEI BRAS of dhcp lease time is 3 days, and in dhcp standard, the modem send dhcp message to BRAS to check whether he can continue using that ip or not just after 0.5 * dhcp_lease_time, wich means 0.5 * 3 days = 1,5 day after operation done by Customer.
So after the operation, even if modem send traffic, so the BRAS Discard that traffic because for BRAS those suscribers are off-line.




Suggestions
To avoid, that accident here is One Smart Method that should be done by the DATACOM Engineer :

Before Cut the suscribers in BRAS and stop the service, a smart method is that:
Few days before the operation, decrease the dhcp_lease_timer like this: ( for example decrease to 6 hours),

[BRAS-ip-pool] lease 0 6 0
( 0 6 0 means: 0 days, 6 hours, 0 minutes)

Wich means, 3 hours after the operation is finished, so suscriber's modem will automatically send the dhcp_request to ask if he can still use the IP, so automatically he will be ONLINE on BRAS, so BRAS will accept and forward his traffic, and the service is recovered.
Notice: after few days the opeartion is done, the Datacom Engineer can restore the value of the timer to it's first value,



END