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Service Interruption Caused by Different Working Modes of Interconnected Optical Ports on RTN 950

Publication Date:  2012-07-25 Views:  37 Downloads:  0
Issue Description
After configuration was modified (such as adding or deleting VLAN IDs) on a router NE40E, services on the connected RTN 950 V100R003C00SPC100 (5.76.03.12)  equipment were sometimes interrupted completely and operations such as adding or deleting services did not take effect. Services were recovered only after the EM6F board connected to the router was cold reseted.
The version is :V100R003C00SPC100


Alarm Information
No alarm is reported
Handling Process
The working modes of interconnected GE optical ports were different. so we change the configuration to have a matched working mode on both RTN 950 V100R003C00SPC100 (5.76.03.12)  and NE40E routers.


Root Cause
Because signals are transmitted over light waves unidirectionally, a GE optical port supports only 1000M full-duplex. The result of auto-negotiation between two GE optical ports can only be 1000M full-duplex. If the auto-negotiation fails, the failed GE optical port reports an alarm indicating that the link is disconnected. Auto-negotiation between GE optical ports is performed when the link recovers and work mode changes from 1000M full to auto. If the working modes of the GE optical ports are changed, auto-negotiation is not performed.

After auto-negotiation between two GE optical ports whose working modes are auto-negotiation is successful, auto-negotiation is not performed again if the working mode of one GE optical port is changed to 1000M full-duplex. Although the working modes of the two GE optical ports are different, services are not interrupted.

However, if you remove and then insert an optical fiber, an alarm indicating abnormal services is reported.
On the live network, the working mode of the GE optical port on the RTN equipment was 1000M full-duplex, whereas the working mode of the GE optical port on the connected router was auto-negotiation. However, services were running properly. An engineer removed and then inserted an optical fiber. As a result, auto-negotiation between the two GE optical ports failed, the router reported an alarm indicating that the link was disconnected, and services were interrupted.

After the EM6F board on the RTN equipment was cold reset, the GE optical port was started before the EM6F board started. Since the default working mode of the GE optical port on the RTN equipment was auto-negotiation, the GE optical port on the RTN equipment automatically negotiated with the GE optical port on the router. After the EM6F started, it downloaded configurations from the SCC board and set the working mode of the GE optical port to 1000M full-duplex. Auto-negotiation was not performed again. Therefore, the working modes of the two GE optical ports were different after the cold reset, but services were recovered.



Suggestions
Ensure that interconnected Ethernet ports have the same working modes.
Either both auto-negotiation or fixed on the same value.


END