No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

No Alarm was reporting to CORBA NBI inetrface

Publication Date:  2012-07-25 Views:  141 Downloads:  0
Issue Description
U2000 V1R2C01 version was running on HA system.As per customer requirement to test some new OSS feature of newly deployed HP server, CORBA NBI needs to be reconfigured. The problem was that after reconfiguration still there was no alarm information reporting to upper level OSS.

Previously running connectivity: U2000 corba NBI                           <--> HP NMS live server  (OK)
Testing connectivity:                     U2000 corba NBI(recongifured)  <--> HP NMS test server (NOT OK)

Reconfiguration has been done according to below steps:
1. Modify the file / opt/U2000/server/nbi/corba/conf/bundlemgr.cfg like the below way through vi tool.
Bundle = ii_base_bundle            (Delete the #)
Bundle = ii_domain_bundle        (Delete the #)
Bundle = ii_corbaagent_bundle   (Delete the #)
#Bundle = ii_mmlagent_bundle
#Bundle = ii_asciiagent_bundle
#Bundle = ii_textagent_bundle
#Bundle = ii_imap_corbaagent_bundle
And then Save.
2. Then login to Maintenance suite and redeploy the corba again below way


Next..

After clicking ok, Corba process will restart.
 
3. Then manually restarted the below corba processes:
itnotify, Agent_CORBA, Notify_Service, Naming_Service
Alarm Information
None
Handling Process
So after properly analysng and doing the research, it was found that one process named UniteUitlDM needs to be restarted along with other process. Also, there is a configuration missing in the \Opt\u2000\server\nbi\corba\conf\ii_corbaagent_bundle\bundle.cfg.

Option for TCA information,which will be added to the end of alarm events.
0: not take TCA,
1: take TCA
AlarmWithTCA = 1 --->>change this value to 0

After changing this TCA value to 0, saving and  manually restarting the below process:
itnotify,
Agent_CORBA,
Notify_Service,
Naming_Service,
United Manager(if not started, start it manually and set starting mode to automatic,

the HP NMS was receiving the real time alarm after that.


Root Cause
Analysis was done according to below steps:
1. Checking on the unbi_corbanotify files on U2000 end to check if the necessary real time alarm was there.
2. Alarm log was found on EMS end(U2000 server) but upper level HP NMS was not getting any even after they have done the necessary tuning on their end.
3. careful search for the NT_ALARM on the  unbi_corbanotify logs and found it there also.




Suggestions
There was lack of proper understanding how CORBA NBI on EMS side actually works for the NMS. Before executing the operation even though it was for testing, through reading of manual is mandatory and very useful in the end.

END