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Cache Data has being Flushed to Hard Disks

Publication Date:  2012-07-18 Views:  14 Downloads:  0
Issue Description
On a deployment site, after a storage device is powered off and then on due to device removal, the cache data of the primary controller has being flushed to hard disks for a long time and the secondary controller is in the abnormal state. The storage device is in safe mode on the Web page. After the storage device is restarted, the fault is rectified. The following messages can be found by querying logs: Apr 7 15:16:29 OceanStor kernel: [1524956]SYS_INFO: Cache flush dirty complete. flag [4], LUN [0],Result[0] //Flushing the data in the cache to hard disks starts. Apr 7 15:30:27 OceanStor kernel: [2363344]SYS_INFO: Remote Cache flush dirty complete. flag [4], LUN [279],Result[0]//Flushing the data in the cache to hard disks stops. During this period, the cache data has being flushed to hard disk and the storage system enters the safe mode. Finally, the storage system becomes normal. Apr 7 15:31:20 OceanStor kernel: [2415695]Alarm ID:-1,Module:47,Type:1,Param:System power on succeeded. was sent to web ui//The storage system becomes normal finally.
Alarm Information
None
Handling Process
Power on the storage system again.
Root Cause
The startup period of the storage system is too long. When a storage device is powered off, the data that has not been written to hard disks is stored in coffer disks temporarily. When the storage device is powered on next time, the dirty data will be written to hard disks. In this case, the storage device has one controller enclosure and seven disk enclosures. Each enclosure contains 21 disks and 168 disks in total. A total of two hundred and eighty 200 GB LUNs are configured on these disks. Before the first power-on, dirty data is stored in coffer disks. After the power-on, the storage system takes about 20 minutes and 15 minutes to connect disks and flush the dirty data to disks. The details are as follows: Apr 7 14:57:19 OceanStor kernel: [374567]softver:1030320409,node [ST3500320NS:SN06:ES2_250G_500G_SN06.bin],disk[ST3450856FC:0005]//First disk connection Apr 7 15:15:52 OceanStor kernel: [1487523]softver:1030320409,node [HDE721010SLA330:ST6OA3AA:HT1T_A3AA.bin],disk[ST3450856FC:0005]//Last disk connection Apr 7 15:16:29 OceanStor kernel: [1524956]SYS_INFO: Cache flush dirty complete. flag [4], LUN [0],Result[0] //Flushing the data in the cache to hard disks starts. Apr 7 15:30:27 OceanStor kernel: [2363344]SYS_INFO: Remote Cache flush dirty complete. flag [4], LUN [279],Result[0]//Flushing the data in the cache to hard disks stops. During the process, the startup status of the storage system is Flushing the dirty data and the storage system is in Safe mode on the Web page. This is a normal phenomenon. The storage system will be successfully powered on. Apr 7 15:31:20 OceanStor kernel: [2415695]SYS_INFO: Local controller status:[1] Apr 7 15:31:20 OceanStor kernel: [2415695]SYS_INFO: Peer controller status:[1] //[1] indicates a normal state, that is, the local and peer controllers become normal at 15:31. Apr 7 15:31:20 OceanStor kernel: [2415695]Alarm ID:-1,Module:47,Type:1,Param:System power on succeeded. was sent to web ui //The storage system becomes normal finally. After the storage system is restarted for the second time, it has no dirty data. Therefore, the storage system is started soon.
Suggestions

When many LUNs are configured and services are running in a storage system, do not power off the storage system to avoid this fault. The normal power-off procedure is as follows:

 1. Stop services on the host.

 2. Power off the host.

 3. Power off the storage device after the disk indicator is off (no dirty data exists in the cache).

END