No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

How to Troubleshoot the Fault that a Large Number of Error Code is Generated because

Publication Date:  2012-07-20 Views:  112 Downloads:  0
Issue Description
1. The S5100 is connected to an FE switch. The ports on the switch that are connected to the service network ports are properly bound.
2. When services run on the S5100, a large amount of error code is generated. You can log in to the OSM and choose Performance > iSCSI Error Code to check the statistics on error code.
Alarm Information
None
Handling Process
Step 1  Run the ethtool command to set the S5100 to full-duplex mode forcibly.
Step 2  Run the debug bash command to go to the background.
Step 3  Run the ethtool -s eth? autoneg off command. 4. Run the ethtool -s eth? duplex full command
Root Cause
1. The service network ports on the S5100 and the network ports on the switch are not mapped. After these ports are mapped, error code still exists. Therefore, link fault is excluded.
2. R&D engineers find that the working modes of the S5100 and the FE switch are inconsistent. The S5200 network adapter works at the rate of 100 Mbit/s in half-duplex mode, while the FE switch works at the rate of 100 Mbit/s and in full-duplex mode. This is why a large number of iSCSI error code is generated
Suggestions
If a GE network is required later on, you can run the ethtool -s speed 1000 command to change the rate of the switch to 1000 Mbit/s.

END