No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

The open iscsi’s version doesn’t match with the redhat OS’s version lead the host can’t connect to the storage

Publication Date:  2012-09-18 Views:  49 Downloads:  0
Issue Description
The customer can’t mount hard disk by iSCSI in a site.  We can find the iqn number, but can’t register the target. It will show that there are some problems in iSCSI’s drive.
The system edition: redhat 5.2
iSCSI edition: iscsi-initiator-utils-6.2.0.695-0.5.i386.rpm
Alarm Information
Null
Handling Process
Install the OS’s iSCSI, it usually in the first disk. After install, key in iscsiadm –m node –p targetip –l to make the initiator work.
Root Cause
Key in iscsiadm -m discovery -t st -p targetip, we can find the initiator’s name.
Key in iscsiadm –m node –p targetip –l, we can’t login, and it shows there are some problems in iSCSI’s drive.
The iSCSI using by customer is open iSCSI which is downloaded from website. The edition in redhat 5.2 is: iscsi-initiator-utils-6.2.0.868-0.7.el5.i386.rpm.
So the reason is that open iSCSI’s edition isn’t same lead S2600 can’t connect to the host by iSCSI.
Suggestions
The open iSCSI edition should match with the OS edition. Don’t download iSCSI from website which is not compliant. Please use the iSCSI in OS install disk.

END