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8220 self-help escalation fault because of SP2 firewall

Publication Date:  2012-09-26 Views:  81 Downloads:  0
Issue Description
When 8220 self-help upgrade, system prompts “Failed to connect to the server”. 
Alarm Information
1. Failed to connect to the server.
2. Background shows FTP IP 0 as below:

[ftp_interface.c][111] FTP->Msg:Ftp task start ok!
[ftp.c][462] FTP->Msg:bind socket ok(1975)!
[ftp_interface.c][180] FTP->Msg:Send MESSAGE_FTP_CONNECT OK!
FTP IP 0
->
code = 0,ret=0,answer type = 6
->
[ftp.c][2267] FTP->Warning:Connect timeout!
[ftp.c][229] FTP->Msg:Disconnected with server!
[ftp_interface.c][218] FTP->Msg:return share memory to debug.
[ftp_interface.c][238] FTP->Msg:Send MESSAGE_FTP_STOP OK!
[ftp_interface.c][243] FTP->Msg:return share memory to debug.
[ftp.c][229] FTP->Msg:Disconnected with server!
->
Handling Process
1. Check parameters, FTP address, user name and trail. All of them are normal.
2. UPGRADE has been changed to VPUPGRADE.
3. FTP testing, we cannot logon system with other except our notebook. At last, we find this problem causes by SP2 firewall.
Root Cause
1. 8220 escalation parameter is set wrong.
2. The configuration in VPUPGRADE file is wrong.
3. FTP is established faulty, and terminal can receive IP 0 but cannot obtain IP address.
Suggestions
1. Pay attention to the SP2 firewall in windows XP.
2. Test system with the installed and upgradable FTP
3. Notice the UPGRADE OemID, edition number, and set the trail as “.\” in 8220.

END