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The frame freezing problem caused by the limit of OS network cache

Publication Date:  2012-09-29 Views:  39 Downloads:  0
Issue Description
Use eIVS V100R001C21 version to view live video, the video frame freezing in play window, the movement is not continuous.
Alarm Information
None
Handling Process
1,Ping the network between server and camera we find no packet loss with little delay, so the network is OK
2,Log in the web interface of the camera we find no frame freezing
3,Examine the configuration of media unit and we find is normal. The fault is located by research and development colleague and it is caused by platform lost frame.
4, Refer to the installation and debugging of NVS, we find eIVS had not optimized the network cache. We use vi amend /etc/sysctl file as follow:
      net.core.rmem_default=1249280
      net.core.rmem_max=1310710
      net.core.wmem_default=124928
      net.core.wmem_max=131027
Restart media server, the video become OK, the problem is resolved.
Root Cause
1,Examine the network between system and peripheral unit whether OK.
2,Whether the camera’s image is OK
3,Examine the configuration of platform multimedia unit and find a error
4,Amend the configuration of system cache reference to NVS platform
Suggestions
None

END