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The system hasn’t configured the hot spare disk or it has been used when the RAID reconstructing, which caused an alarm

Publication Date:  2012-11-05 Views:  33 Downloads:  0
Issue Description
Product and Version: adapting to CSS-D V100R001C00 product
There is an alarm information “0xB0216000A RAID card hot spare disk alarm” on the ISM management interface.
Alarm Information
“0xB0216000A RAID card hot spare disk alarm”
Handling Process
Step 1. Execute the command: “MegaCli64 -pdlist -aall | grep Unconfigured -B12”, check it there is idle hard disk, as the picture 1-2 displayed:
Picture 1-2 view the hard disk’s status

-If there is a hard disk whose “Firmware state” is “Unconfigured(bad)” in the system, please replace this hard disk, and then execute the step 2.
-If here is a hard disk whose “Firmware state” is “Unconfigured(good)” in the system, which denotes that there is a idle hard disk, execute the step 2 directly.
Step 2.Execute the command “MegaCli64 -pdhsp -set physdrv [E:S] -aall”, configure the global hot spare disk. Where the parameter “physdrv” assigns the disk which is used to configure the hot spare disk, the “E” in the “[E:S]” denotes the enclosure device ID, and “S” in the “[E:S]” denotes the slot device ID.
Step 3. Execute the command “MegaCli64 -pdlist -aall | grep Hotspare$ -B12”, check whether there has been configured the global hot spare disk in the system. If there is a hard disk whose “Firmware state” is “Hotspare”, such as displayed at the red pane in the picture 1-1, it denotes that the system has configured it. Or, please contact the research engineer.
Step 4. Check the alarm information“0xB0216000A RAID card hot spare disk alarm” in the ISM management interface, and see whether it has been recovered.
-YES. => Fault has been clear out, resolve completely.
-NO. => Please contact the research engineer.
Root Cause
1. According to the alarm information, check the online status indictor of the hard disk where the alarm comes from, we find it is green, which denotes the hard disk is normal.
2. Login in the device which has the alarm via the “root” user.
3. Execute the command “MegaCli64 -pdlist -aall | grep Hotspare$ -B12”, check if the system has configured the global hot spare disk, the outcome is empty, which denotes that the system hasn’t configured the hot spare disk or the hot spare disk has been used when the RAID group reconstructing.
Instruction: If there is a hard disk whose “Firmware state” is “Hotspare”, such as displayed at the red pane in the picture 1-1, it denotes that the system has configured the hot spare disk.
Picture 1-1. View the system hard disk


Then, we conclude that this fault is caused by there isn’t hot spare dick or it has been used when the RAIN group reconstructing.

Suggestions
None

END