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The hard disk has fault but the system hasn’t configured the hot spare disk, and then caused the RAID group degrading

Publication Date:  2012-11-05 Views:  79 Downloads:  0
Issue Description
Product and version: adapting to the CSS V100R001C00 database fascicule
When initializing the RAID group, there appeared the alarm “0xB02160001 RAID group degrading” in the ISM management interface.
Alarm Information
There appeared the alarm “0xB02160001 RAID group degrading” in the ISM management interface, and the online indicator of the hard disk was red.
Handling Process
Step 1. According to the alarm content, replace the fault disk.
Step 2. Check whether there is the alarm “0xB02160002 RAID group start to reconstruct” on the ISM interface.
-YES => Step 3.
-NO => Step 4.
Step 3. Waiting for several minutes, then check whether there is the alarm “0xB02160003 RAID group has reconstructed successfully” on the ISM interface.
-YES => the fault has been solved, it’s over.
Step 4. Login in the device that appears the alarm information via the “root” identity
Step 5. Execute the command “MegaCli64 –adpautorbld –enbl –aall”, set the LSI RAID card as automatically reconstructing.
Step 6. Execute the command “MegaCli64 -pdhsp -set physdrv [E:S] -aall”, set the new disk as the hot spare disk. Where the parameter “physdrv” assigns the disk which is used to configure the hot spare disk; he “E” in the “[E:S]” denotes the enclosure number, and “S” in the “[E:S]” denotes the slot number.
Step 7. Execute the command “MegaCli64 –pdinfo –physdrv [E:S] –aall”, view the hot spare disk’s status, as displayed in the red frame of the figure 1-2. Where the parameter “physdrv” assigns the disk which is used to configure the hot spare disk; he “E” in the “[E:S]” denotes the enclosure number, and “S” in the “[E:S]” denotes the slot number. We can execute the command “” to check the enclosure Device ID, pay attention to the case sensitivity in the command line.
Figure 1-2. View the disk’s status


-If the “Firmware state” is “Online”, it shows that the reconstruction has completed.
-If the “Firmware state” is “Rebuild”, it shows that the reconstruction is being on, wait patiently till it complete.
Step 8. Check if the alarm “” in the in the ISM management interface has recovered.
-YES => the fault has been solved, it’s over.
Root Cause
1. According to the alarm information, check the online indicator of the hard disk in the alarmed device, we find it is red.
2. Login in the alarmed device via the “root” identity.
3. Execute the command: “MegaCli64 -pdlist -aall | grep Hotspare$ -B12”, check if there is configured the global hot spare disk, we find the outcome is empty, it’s denotes that the system hasn’t configured the hot spare disk or it has been used by the RAID reconstruction. If there is a disk whose “” is “” in the disk information, such as displayed in the red frame of the figure 1-1, which denotes the system has configured a hot spare disk.
Figure 1-1 check the system’s hard disk


Then, we conclude this fault is caused by the disk’s problem and the system hasn’t configured the hot spare disk.
Suggestions
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