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A method to settle the problem that the Smartinstall searching the Galax information failed

Publication Date:  2012-11-14 Views:  43 Downloads:  0
Issue Description
There is the simplified configuration desktop cloud with the version of SingleCLOUD V100R002C01 at an experiment site. We use the SmartInstall tool to install the “vdesktop”, in the “configuration” webpage, write in the MCNA IP, account, password, ESC IP, and then click “search”, there appears the following red error prompt in the bottom of the webpage: “haven’t searched any valid cluster information, please check whether the ESC information configuration is right!”; click the “search” again, there appears the following prompt: “Can not connect to (ESC IP)”; search for the third time, there appears the prompt: the “C:\SmartInstall\SoapClient\GalaxUser.p12” is using by another process, so you can’t access this file. Then we can’t keep on using the SmartInstall tool, and it must be closed and opened again.

Alarm Information
None
Handling Process
1. It can ping through the ESC node’s IP in the MCNA01, so we exclude the network configuration’s problem.
2. Login in the MCNA via Putty and enter “data”, compare with the local computer’s time, it is accordant with the site’s.
3. Enter the “java -version” at the command prompt character according to the manual, we find the version of the java is over 1.6.0_20.
4. Check the time log in the “C:\SmartInstall\log”, we find the reason of connecting Galax error is : “Connect to Galax failed ,exception unwrapping private key - java.security.InvalidKeyException: Illegal key size”. Analyze furthermore, we find it used the “jdk sercurity” when installing, however, there is limitation of the technology export in the jar package “$JAVA_HOME/lib/security/local_policy.jar” and “$JAVA_HOME/jre6_64/lib/security/US_export_policy.jar”, and the encrypted one is just 128bit, the unlimited one is 256bit. The two encryption methods are not consistent, which causes there appearing error while the SmartInstall searching the Galax information. We should use the consistent jar, the method to replace it is as followed:
Environment: JDK1.6
1) Download the “Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files 6” on the website “http://www.oracle.com/technetwork/java/javase/downloads/index.html”, and then get the package “jce_policy-6.zip”.
2) Decompress the “jce_policy-6.zip”, take the “local_policy.jar” and “US_export_policy.jar” in this package to cover the corresponding files in the catalog of “%JAVA_HOME%/jre/lib/security”

Besides, you can download the attachment, and then compress it, take the “local_policy.jar” and “US_export_policy.jar” in this package to cover the corresponding files in the catalog of “%JAVA_HOME%/jre/lib/security”

Root Cause
1. The network information is configured incorrectly.
2. The local computer’s timestamp is different with the Galax’s
3. The version of the jre or jdk is incorrect.

Suggestions
None

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