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IPush prompts payment business, testing account hasn’t push the prompting payment advertisement

Publication Date:  2012-11-16 Views:  40 Downloads:  0
Issue Description
In a site, the customer uses testing account test prompting payment business push, push interval is configured for 10 minutes, the user daily delivery times is configured for 255 times, lasts 2 hours, has not received the prompting payment business advertisement.
Alarm Information
None.
Handling Process
1, Login the NetS DB located server, then input:
mysql -DNETS -pSigV19@80
2, check the owe user’s balance, need to inquires the owe list:
mysql> select * from IPUSH_FEE_SYNC where ACT = '0XXXXXX0886';
Empty set (0.28 sec)
3, owe list has no records, need to do further position, check the synchronous original data list, find the balance is 33 Yuan:
mysql> select * from IPUSH_CONF_DAY_NOTIFY_FILE where ACT='0XXXXXX0886';
+---------+-------------+-------------+---------+---------+-----------+------------+
| AREA_ID | SUB_AREA_ID | ACT         | ENDDATE | BALANCE | USER_TYPE | CREATETIME |
+---------+-------------+-------------+---------+---------+-----------+------------+
|     810 |           0 | 0XXXXXX0886 |       0 |      33 |         2 | 1309973401 |
+---------+-------------+-------------+---------+---------+-----------+------------+
1 row in set (0.33 sec)
4, the cause of the problem is as a result of test account balance hasn’t matched to the audience group rules, so it doesn’t enter the group.
Root Cause
 Account hasn’t received the prompting payment advertisement, there may exist a lot of, in the debugging, first of all need to confirm which of the following situations it is:
1, this account is not in the prompting payment audience group;
2, the account is in the prompting payment audience group.
 These two points are the most easy to determine in the prompting payment debugging link, once chosen one of them, it confirmed the different problem positioning direction, makeup positioning direction is as follows:
1, this account is not in the prompting payment audience group - - - - > what causes the account is not in designated audience group;
2, the account is in the prompting payment audience group - - - - > what causes it hasn’t received, whether it hasn’t pushed or pushing failed.
By determining orientation direction, inspect the prompting payment audience group, found that the user is not in the audience group, check the inbound rules of audience group are: the balance is 0-30 Yuan. Need to consider what causes the account is not in audience group.
Suggestions
The reasons to the problem that the prompting payment hasn’t received are very much, proposal gradually positioning according to the steps.

END