No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

FAQ:Why it cannot capture the packet but layer 2 far distance mirroring configuration is correct

Publication Date:  2012-11-19 Views:  9 Downloads:  0
Issue Description
Q:
Why it cannot capture the packet but layer 2 far distance mirroring configuration is correct?
Alarm Information
NULL
Handling Process
A:
If it confirm the configuration is correct, but it failed, it can try: on S9300 next level device, under mirroring vlan, use mac-address learning disable to close MAC address learning.
Because it made both direction on S9300, source MAC and destination MAC will interact for the mirroring data packet, as the following case: the source mac is its mac1 for server sending packet, but the destination mac is server mac1 for the reply packet, so after both direction mirroring, it makes that s9300 next level device s5300 connecting S9300 interconnection interface learn the server mac1 address, but for receiving packet,its destination MAC is mac1, it is the mac1 learnt by S5300 its local interface, S5300 will discard, it will lead both direction far distance failing.

case:the key configuration of device is as follows, all configuration is in attachment:
server(MAC1) -----(G1/0/0)9300(6 7 interface)====convergence====(22 33 interface)S5300(1 interface connecting with packet capturing PC)

9300 key configuration:
observe-port 1 interface GigabitEthernet1/0/6 vlan 13

interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 2 to 4094

interface GigabitEthernet1/0/0
port-mirroring to observe-port 1 both

S5300 key configuration:
vlan 13
mac-address learning disable

interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 2 to 4094

interface GigabitEthernet0/0/1
port link-type access
port default vlan 13

Root Cause
NULL
Suggestions
The basic element of layer 2 forwarding, if the accessing data packet destination mac maintenance on the local interface, it will be discarded.

END