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A method to settle the problem that the client can’t mount the N8000 share file

Publication Date:  2012-12-04 Views:  66 Downloads:  0
Issue Description
We find the client can’t mount the share file system provided by the N8000.

Alarm Information
None
Handling Process
Step 1. Check whether the file system has mounted in the client normally.
Execute the command “df -h” in the Linux client, and check whether the mounting file system can display normally. If it can’t return the capacity information of the mounting file system, it illustrates that the NFS server between the client and the N8000 has problem.
Step 2. Check whether the network connection is normal.
Implement the ping command in the client, and check whether the service IP of the N8000 can communicate with the client normally. In the N8000 end, check whether the other service IP is in the “online” status. To know the detail method to check the N8000 IP via the ISM, please refer to the 《Oceanspace N8000 cluster NAS storage system, configuration manual, NAS service volume》.
If it can’t ping through the connection and the service IP displays as the status is “offline”, please check the network connection between the client and the N8000, and exclude the network problem.
Step 3. Reuse the right mounting parameter and mount the share file system in the client.
Execute the command “mount –t nfs -o timeo=10 192.168.28.39:/vx/nfstest  /mnt”, where “192.168.28.39” is the service virtual IP address provided by the N8000 cluster NAS storage system, “/vx/nfstest” is the name of the NFS share file system, “/mnt” is the client mounting node. We suggest adding the “-o timeo=10” at the “mount”, and configure the time of “NFS Retry”.
If mounting failed, we can firstly consider the problem is caused by the client but not the N8000.
We suggest replacing the client and re-implement the “mount” testing.
Step 4. Check whether the reason of the mounting failed is the mounting is overtime.
If the client mounting overtime, we need to check whether the DNS service of the cluster NAS storage system is open.
Check whether the DNS configuration is right.
Step 5. Enter in the N8000 and view the N8000 share information.
To see the method to check the status of the NFS and CIFS share service via the ISM, please refer to 《Oceanspace N8000 cluster NAS storage system, configuration manual, NAS service volume》.
Step 6. Start the NFS share or CIFS share service.
If there appears a node’s service of the NFS or CIFS is in the “forbidden” status. Please restart the NFS share or CIFS share system after confirming this node isn’t fake dead.

Root Cause
The client can’t mount the share file system provided by the N8000, there are several possible reasons: N8000 server’s problem, the network’s problem and the client’s problem, etc. We should exclude the problem one by one, and then we can settle the problem after confirming the reason of the problem.

Suggestions
None

END