No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

SQL server error during Witness installation

Publication Date:  2013-02-12 Views:  57 Downloads:  0
Issue Description
While we are in the process of SingleCloud VDesktop deployment, there is a SQL server error happened during installation of Witness. The error message is:
818 Witness-01:Failed to connect to the database of the current IP address by using the SA password of the active database.(ERRORCODE=I060035)
626 Failed to install the role Witness-01. The error code 326 is returned.
Alarm Information
For detailed error information, please check the following red labeled error message:
Handling Process
1. As this is a SQL server error, first try to search the error code I060035 from Microsoft website. Unfortunately, there are only error codes from 1 to 35999 for SQL server 2008 R2 in Microsoft website:
http://msdn.microsoft.com/en-us/library/cc645603(v=sql.105).aspx

2. From the error message itself, we can see that this error is caused by a failed login with account SA. And we can check our configuration file to find the SA account’s password. Please see the red labeled line in the following picture:


3. To confirm if it’s SA account’s password issue, try to login to database engine in SQL server management studio with SA account and password. It fails too. This confirms that the SA account and password is not correct.

4. Login into database engine with another administrative account, manually change SA’s password to the one in our configuration file. Just like following screenshot:



5. After the SA’s password is changed, try to run Witness again and now it succeeded with no error.
Root Cause
This issue is caused by wrong SA account password in SQL server.
Suggestions
N/A

END