No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

PVID can't be configured in trunk mode

Publication Date:  2013-04-29 Views:  129 Downloads:  0
Issue Description
【Product】NE80E&40E

【Version】V600R001C00SPC800

【Problem Description】Why PVID can't be configured in trunk mode
Alarm Information
N/A
Handling Process
1. There is no command to support configuring PVID in trunk mode.
[NE40E-1-GigabitEthernet1/2/3]disp this
#
interface GigabitEthernet1/2/3
description -- XXX --
undo shutdown
portswitch
port link-type trunk
port trunk allow-pass vlan 3230 3240 3250
#
return

[NE40E-1-GigabitEthernet1/2/3]port ?
  dot1q-tunnel   Dot1.q tunnel
  isolate-state  Port isolate state in vlan
  link-type      Switch port link type
  shaping      Specify shaping parameters
  trunk            Trunk port
  vlan-mapping   VLAN Mapping
  vlan-stacking  VLAN Stacking

[NE40E-1-GigabitEthernet1/2/3]port trunk ?
  allow-pass  Allowed vlan

[NE40E-1-GigabitEthernet1/2/3]port trunk allow-pass ?
  vlan  Virtual LAN

[NE40E-1-GigabitEthernet1/2/3]port trunk allow-pass vlan ?
  INTEGER<1-4094>  VLAN ID
  all              All

Compare with S9300: 
[Quidway] interface GigabitEthernet 1/0/1
[Quidway-GigabitEthernet1/0/1] port link-type trunk
[Quidway-GigabitEthernet1/0/1] port trunk pvid vlan 5

2. PVID info can be shown by command display pvid vlan.
<NE40E-1>disp port vlan
Port                                  Link Type    PVID  Trunk VLAN List
-------------------------------------------------------------------------------
GigabitEthernet1/2/0    access       3210   -                                 
GigabitEthernet1/0/1    access       3230   -                                 
GigabitEthernet1/0/2    access       3120   -                                 
GigabitEthernet1/0/3    access       3120   -                                 
GigabitEthernet1/0/4    access       3100   -                                 
GigabitEthernet1/0/5    trunk           0          3110
GigabitEthernet1/2/7    access       3220   -                                 
GigabitEthernet1/2/3    trunk           0          3230 3240 3250

3. There is no PVID info after executes display interface gigabitethernt
<NE40E-1>disp int g 1/2/3
GigabitEthernet1/2/3 current state : UP
Line protocol current state : UP
Description:-- XXX --
Switch Port,The Maximum Transmit Unit is 1500
Internet protocol processing : disabled
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 286e-d450-63b1
The Vendor PN is ABCU-5710RZ
The Vendor Name is AVAGO
Port BW: 1G, Transceiver max BW: 1G, Transceiver Mode: Copper Mode
WaveLength: unknow, Transmission Distance: 100m
Media type: twisted-pair ,Link type: auto negotiation
Loopback:none, Maximal BW:1G, Current BW:1G,full-duplex mode, Pause Flowcontrol:Receive Enable and Send Enable
Last physical up time   : 2011-12-30 17:25:37
Last physical down time : 2011-12-30 17:25:20
Statistics last cleared:2012-02-20 17:08:48
    Last 300 seconds input rate: 2119552 bits/sec, 2007 packets/sec
    Last 300 seconds output rate: 7776840 bits/sec, 3057 packets/sec
Root Cause
NE80E&40E don't support PVID configuration in trunk mode. Owing to L2 protocol packet is untag packet and router as gateway device in usually, in order to avoid L2 untag packet is forwarded when misconfiguration happens, L2 protocol packet should be terminated in router device. If untag packet must be forwarded, hybrid mode can be used.
Suggestions
N/A

END