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Remove red error icon on VM remotely without console access after storage recovers

Publication Date:  2013-06-07 Views:  56 Downloads:  0
Issue Description
After a storage failure and recovery, some VMs on the recovered storage might be marked with an red error icon. Customer can follow KB1000029422 to clear the error from console. However customer cannot access console in many scenarios. If so, this KB can help to clear the error remotely without console access.
Before you follow this KB to clear error message, you should first check carefully the VM status to make sure if there is any other errors on this VM. If there is no error and the red error icon still doesn’t disappear. This KB can help you to clear it.
Alarm Information
After a storage failure and recovery, some VMs on the recovered storage might be marked with an red error icon, just like the following picture:

Handling Process
1. Log in to SSH or Local console as root.
Note: Difficultly SSH is disabled on ESXi. You should have administrator privilege and manually start it from VCenter.
2.Run these commands:

/etc/init.d/hostd restart
/etc/init.d/vpxa restart

Root Cause
It's a known issue about ESX5i.
You should first check carefully the VM status to make sure if there are any other errors on this VM. If there is no error and the red error icon still doesn’t disappear, please follow this KB to remotely restart the management agent on ESXi.


Suggestions
Restart management agents will disconnect all remote management software. Perform this after you can make sure it’s safe to do so.

END