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Serious echoes with calls via AT0 trunk

Publication Date:  2013-07-02 Views:  97 Downloads:  0
Issue Description
U1930 connect to PSTN via AT0 trunk (FXO ports on OSU). There are serious echoes with PSTN calls, both incoming calls and outgoing calls. But inner calls works fine.
Alarm Information
N/A
Handling Process
Execute blew commands to enable Echo Cancel function for all codec
config system voip algo g711 echocancel on 
config system voip algo g729 echocancel on 
config system voip algo g723 echocancel on 
config system voip algo ilbc_1520 echocancel on 
config system voip algo ilbc_1333 echocancel on 
Then make serval calls via FXO ports for testing. All echoes were removed successfully.
Root Cause
1. check the echo cancel configuration of MRS paramaters by "show mrsparas"
MRSPARAS Information
ECEnable ECTail ErlSel EcCng PlcEnable CngEnable VADEnable VocVolume OutputGain
-------- ------ ------ ----- --------- --------- --------- --------- ----------
1        0      6      1     1         0         0         31        31         
The configuration is ok.
 
2. check the echo cancel configuration of VOIP codec by "show system voip argu algo g711"
System VoIP Arguments
                   PacketTime: 20
                   EchoCancel: [OFF]
                  GainControl: 14
           SilenceSuppression: [OFF]
JitterThreshold(min/max/init): 20(ms)/200(ms)/20(ms)
                    CRCswitch: [NULL]
====  Command executed success !  ====
As we see, the Echo Cancle configuration of codec is OFF, need to enable this function.
 
Suggestions
Some problems releate to more than one configuration. Need to notice all of the releated configurations and check them one by one.

END