No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

how to check the status of the N8000 system and restore the file system manually

Publication Date:  2013-07-29 Views:  94 Downloads:  0
Issue Description
customer had a NFS share before, they store the backup files on the storage, when the file system is fault, they can't access to these files.
Alarm Information
none
Handling Process
we have to check what kind of factor will cause the problem, so we have to carry out the steps bellow one by one:
1. check the status of the array. Login with ISM to check the status of disks, RAIDs and LUNs, if there are alarms, we have to fix it first.
2. check the status of the physical link, run the command ''vxdmpadm getsubpaths'' to check the Ultrapath.
3. check the status of the cluster with the command ''gabconfig -a'' with the support account.
4. check the status of the file system with the commands bellow:
     Run the command ''cfsmntadm display'' to check the status of the mounted file system
     Run the command ''echo “8192B.p S” | fsdb -t vxfs /dev/vx/dsk/sfsdg/file system name |grep flags'' to check if the flag of each file system is normal.
     Run the command ‘vxdg list’ to check if the DG is normal
     Run the command ‘vxdisk list’ to check the status of disks
     we use command ‘scanbus’ to import the DG information if the DG infomation miss
5.  after all the information we checked is normal, we can run the command ''cfsmount /vx/file system name'' to mount the other file system
6. Then with the command ''cfsmntadm display'' to check the status of the mounted file system again.
7. at last run the command ''network ip addr online ipaddress nodename'' to restore the businees IP.
Root Cause
the file system fault may be caused by the factors bellow:
1. the physical link between the N8000 and backend array is break down
2. the LUN is fault in the array
3. the cluster service is abnormal at this moment
Suggestions
none

END