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All the cameras corresponding to one IVS MU stop recording at the same time.

Publication Date:  2013-07-31 Views:  16 Downloads:  0
Issue Description
From the video record searching result, we find that many cameras stop recording at the same time and never start again.
Alarm Information
None
Handling Process
We must manually delete all the residual files, otherwise the problem will recur.
Operation:
1. Check if there is residual index information in the database. If yes, delete it. The operation is described detailedly below by example.
Note:Before operating in the database, must backup up the database. The backup method is: right click the database name and select the backup database. If there is any database operation failure, we can recover it by the backup file.
i. Query the index information for camera “029001000010101” and order the result by recording start time.
select * from tbl_record_data t where t.camera_code = ‘029001000010101’ order by t.start_time
ii. Query the index information recorded before a time point for camera “029001000010101” and order the result by recording start time.
select * from tbl_record_data t where t.camera_code = ‘029001000010101’ and t.start_time < ‘20121001000000’ order by t.start_time
iii. Delete the index information recorded before a time point for camera “029001000010101”
delete from tbl_record_data t where t.camera_code = ‘029001000010101’ and t.start_time < ‘20121001000000’
iv. Delete the index information before a time point for all cameras
delete from tbl_record_data t where t.start_time < ‘20121001000000’
v. Query all the index information stored on one MU
select * from tbl_record_data t where t.mru_code = ‘00000001106020000002’
2. Check if there is residual index file in the index file directory. If yes, delete it. The operation is described detailedly below by example.
Note: All the index files for one camera will be stored in the same directory, and further kept in sub-folders named by time. This directory is configured by the “RecordIndexPath” field in the ivs_mru_record.conf file, which is stored in the /home/ivsmu/mru/conf directory. For example, most of the case, this field is configured as “RecordIndexPath=/mrumnt/RecordIndexFile”
i. Query the index files for camera 029001000010101
find/mrumnt/RecordIndexFile/029001000010101 –name *.idx
ii. Query the index files generated in Sep 2012
find /mrumnt/RecordIndexFile/ –name 201209* -type d
iii. Delete all the index files generated in Sep 2012 (be careful, this operation is not reversible)
find /mrumnt/RecordIndexFile/ –name 201209* -type d –exec rm –rf {} \;
3. Check if there is residual record file on the disk. If yes, delete it. The operation is described detailedly below by example.
Note: The record files will be stored on different luns and different Raid groups. The directory on each lun for one camera will be named by its device id and further named the sub-folders by time.
i. Query the record files for camera 029001000010101
find /mrumnt –name 029001000010101 –type d
ii. Query the record files generated in Sep 2012
find /mrumnt –name 201209* -type d
iii. Delete all the record files generated in Sep 2012 (be careful, this operation is not reversible)
find /mrumnt –name 201209* -type d –exec rm –rf {} \;
Root Cause
1. By analysis, we notice that all the stopped cameras belong to the same MU and all the cameras corresponding to this Mu have stopped video recording.
2. Check if the ivs_mru_record process runs normally, the result is yes. Then tried to resolve the problem by reboot the server or mu service, both failed.
3. Checking the platform recording plan for these cameras, found all the plan have changed from all-day recording to stop. Manually start it again, the recording can be recovered.
4. Keep on to find the root cause for this problem by reading the MRU log files, found many abnormal information, as below.
2012-11-20 01:58:56.154880 [ERR] [0x79a28ba0] | (DeleteManager.cpp:1040)  Delete record file failed. Index file path=/mnt/record_indexfile/000000000430104/20120517/20120517185150_20120517185331_P000.idx
2012-11-20 01:58:56.166343 [WAR] [0x79a28ba0] | (DeleteManager.cpp:1074)  No file can be delete, so stop record.
2012-11-20 01:58:56.166352 [WAR] [0x79a28ba0] | (FileEgress.cpp:481)  Camera=000000000430104 over ride disk fail, Full Policy=1.
2012-11-20 01:58:56.166370 [WAR] [0x79a28ba0] | (FileEgress.cpp:1454)  Camera=000000000430104 override disk fail, so stop record.
This information tells us the service encounters failure when trying to delete the record files stored from May to Jul, when the system is being deployed and commissioning. During that period, many inconsistent index files, record files and database index appears, which leads to the failure of deleting old files when execute the “Overflow policy” and further leads to record stop.
Suggestions
During the system commissioning period, due to some abnormal operation, there will always have some inconsistent index files, record files or database index information. After commissioning, must remember to delete them.

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