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eSpace U1911 fialed to leave messagae for PSTN voice message box.

Publication Date:  2013-12-06 Views:  42 Downloads:  0
Issue Description
topology: U1911---AT0---PSTN
version: V100R001C01SPC300
problem: eSpace U1911 dial to PSTN via AT0 trunk, the call reach to Voice message box when the cell phone didn't answer the call, but when hear the tone to leave the messages, the internal caller was released.
Alarm Information
no
Handling Process
1. Capture U1911 call logs, make some test and found below messags in the log:

[73][0x00000085][2013-12-01 01:43:35.43][At0.c 5148]Received signal tone: Busy tone
[42][0x00000085][2013-12-01 01:43:35.43][At0.c 5244]
[104][0x00000085][2013-12-01 01:43:35.43][At0.c 6033]dwTsn=[   0] AT0_SendMsgToCCM [dwCCMNo =  134 ] --->DISCONNECT
[112][0x00000085][2013-12-01 01:43:35.43][At0.c 7308]dwTsn=[   0] AT0_SetCRState [ CRNO =  611] {RUN--->I_WAIT_RELEASE_COM}
[78][0x00000085][2013-12-01 01:43:35.43][ccm.c 2870][dwCCMNo=  134] CCM_ProcStateCallMsg
[103][0x00000085][2013-12-01 01:43:35.43][ccm.c 21869] CCM_ProcStateCallMsg:::<-  MsgType = EN_Q931_MSG_DISCONNECT
2. Check the log, we can found it was due to U1911 think the leave message tone as busy tone, then release the call .
3. Modify the busy tone detection range(usually it was the standard tone ±25HZ), but until modify it was ±1HZ the problem was not solved.
4. But ±1HZ range was too small, it may cause the real busy tone cann't be found.
5. Checking with R&D, it was due to the leave message tone was very close with busy tone.
6. Current system will think it was a busy tone when found one cycle busy tone, after R&D develop a patch which will think it was a busy tone when found three cycle busy tone
7. Activated this patch, then test, the problem was solved.
Root Cause
1. It was U1911 released the call, may due to the system check some tone as release tone.
2. It was PSTN released the call, may due to some parameter is not matched, need PSTN help check.
Suggestions
After add the patch, when PSTN hang up the call, it will have a little delay for internal call hang up.

END