No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Not being able to configure a CX-911 switch on a E9000 server

Publication Date:  2014-05-05 Views:  310 Downloads:  0
Issue Description
The customer reported that while studying the configurations on the four CX-911 switches they have in two E9000 blade enclosures,  they encountered a problem with one of the switches.
After logging in with telnet as user root, there seems to be is a set of commands missing.
The customer is not allowed to give any config commands, it is also not possible to view anything. A "disp cur" is not recognized. Trying to connect with a console cable was also not succesfull.
Alarm Information
user root missing some commands.

<USER>disp cur
           ^
Error: Unrecognized command found at '^' position.

<USER>sys
Enter system view, return user view with Ctrl+Z.

[USER]reboot
      ^
Error: Unrecognized command found at '^' position.
Handling Process
Suggested to customer to test some other commands like #display device# , #display version# and even #reboot#. If the first two display commands worked fine (see below) , the reboot command did not worked.

<USER>disp dev
Frame Number            : 1
Slot Number             : X3
Device Description      : OSCA SWITCH BOARD XCUA, Fabric


<USER>disp dev
Frame Number            : 1
Slot Number             : X3
Device Description      : OSCA SWITCH BOARD XCUA, Fabric
<TSW06HK8-10G-RIGHT>disp ver
BoardName                : CX911
CPLD Version             : 008
PCB Version              : VER.C
rcw Version              : 001
backup rcw Version       : 001
Bootrom Version          : 019
Creation Time            : Jun  3 2013, 16:29:03
Backup Bootrom Version   : 019
Creation Time            : Jun  3 2013, 16:29:03
Switch Version           : 1.1.3.300.5
Creation Time            : Jun 15 2013, 15:54:38
Backup Switch Version    : 1.1.3.300.5
FC BoardName             : M8WA
FC PCB Version           : VER.B

The solution was that the customer needed to connect to iMANA and change the behaviour of the switch console interface.Then he could login to the console and change the priviledge level of user root to 15.That solved the problem.
Root Cause
User root did not have enough privileges to run some commands.
Suggestions
When dealing with this kind of issues in the future please pay extra attention to the level of priviledge your user have.If current user has a priviledge lower thatn 15 than you must check what each priviledge level means.To be sure that every command can be issued , level 15 must be selected.

END