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U1960 using AT0 trunk, the incoming call is no caller ID display

Publication Date:  2014-05-24 Views:  163 Downloads:  0
Issue Description
some site in Bangladesh, the U1960 version is V100R001C01SPC400.
U1960 use AT0 trunk, the incoming call is no caller ID display or display 000.
Alarm Information
none
Handling Process
1. first check the AT0 open the caller ID display service or not. engineer can use a analog phone directly connect to AT0 line to check. if can see the caller ID display, follow the below step.

2. make sure the signal is FSK or DTMF. FSK caller ID display must be after the first ring, if it displays when phone rings, it must be DTMF. if we judge it is the DTMF signal, only U19XX V100R001SPC700 version can support.
U19XX related config:
config cid parameter cidmode <fsk | dtmf> cidtime <beforering | afterring>,
set the caller ID display format and detect time, default is fsk/after ring

3.meanwhile, U19XX also supports set the timer caller ID display:
config modify timerinterval pid at0 timergroup 0 timerindex <> interval <>.
as for 1910/1930,timerindex is 30; as for 1960,timerindex is 31; interval is the time length of timer.

Root Cause
1. the telecom company side does not open caller ID display service.
2. the AT0 lines is too long, so signal strength sent to PBX by AT0 trunk is little, PBX can not detect.
3. the telecom use DTMF sending caller number, U19XX only at V100R001C01SPC700 version can support DTMF.
4. the telecom sending the caller ID display signal is not standard. The process is: AT0 module will start a 0.5s timer when it receives a response for the session , when the timer overtime it starts to detect caller ID display . Why set to 0.5s, because the standard set that time interval between "the first ringing over" and "begin to transfer FSK number" is 0.5s~1.5s. But the present network environment is different, can not meet the standard for every country. another matter is caller ID display signal does not meet national standards.
Suggestions
none

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