No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Monitoring Tecal E6000's health

Publication Date:  2014-07-17 Views:  87 Downloads:  0
Issue Description
The customer let me know the IT monitoring platform reports alarms:

Alarm Information
None.
Handling Process
Procedure:

1. Fan and chassis alarms failed to be cleared since January 24.

2. Log in to the management module web user interface (WebUI) using the MM610 floating IP address (10.197.80.134). No alarm is found, but management module active/standby switchover logs are generated when alarms are generated.

3. The IT monitoring platform monitors the E6000 through snmpwalk commands and uses the MM1 static IP address (10.197.80.132) in commands for monitoring. When an MM610 active/standby switchover occurs, the MM1 becomes standby. In this case, if the MM1 static IP address is used in snmpwalk commands to query the fan and power supply unit (PSU) status, incorrect results will be displayed, and the IT monitoring platform reports false alarms, see below:



4. Trigger an MM610 active/standby switchover. Then alarms are cleared.
Root Cause
I informed him when the IP address of the standby MM610 is used in snmpwalk commands to query the fan and PSU status, the fan and PSU status cannot be obtained and incorrect status is displayed. As a result, the IT monitoring platform reports false alarms.
Suggestions
When the IP address of the standby MM610 is used in snmpwalk commands to query the fan and PSU status, the fan and PSU status cannot be obtained, and incorrect status is displayed. As a result, the IT monitoring platform reports false alarms.

Solution

1. Workaround
Method 1: Trigger an MM610 active/standby switchover.

a. Log in to the active MM610 using the MM610 floating IP address (or the static IP address of the current active MM610) over Telnet or Secure Shell (SSH). Then run smmset -d failover -v 1 to trigger an active/standby switchover.

b. If hardware can be operated onsite, remove and reinsert the active MM610 to trigger an active/standby switchover.
Method 2: Change the MM610 IP address in monitoring scripts to the IP address of the current active MM610.

Solution
Change the static IP address of MM1 in snmpwalk commands to the MM610 floating IP address (ensure that the client can access the MM610 by the floating IP address through routes).

snmpwalk command format:

snmpwalk -v 3 -u root -l authPriv -a MD5 -A huaweiosta -x DES -X huaweiosta MMIP OID

-v 3: indicates SNMPv3.
-u root: indicates the user root who is using the system management module.
-l authPriv: indicates the security level. The authentication and authorization security level is used.
-a MD5: indicates the authentication protocol. The message digest algorithm 5 (MD5) is used.
-A huaweiosta: indicates that the password huaweiosta of user root of the system management module is used for authentication.
-x DES: indicates the encryption protocol. The Data Encryption Standard (DES) is used.
-X huaweiosta: indicates that the password huaweiosta of user root of the system management module is used for authentication.
MMIP: indicates the system management module IP address.
OID: indicates the object identifier (OID) of the management information base (MIB) node to be queried.

END