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Hot Spare disk still occupied and did not change to Free state after replacing the faulty hard disk by good one

Publication Date:  2014-11-06 Views:  76 Downloads:  0
Issue Description
Device Model: Oceanspace S2600
Product  version: V100R005C02

symptom:
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- we received a request from our customer that he has a faulty hard disk.
- after we checked the logs ,confrimed that this hard disk is broken and needed to be replaced.
- delivered good hard disk to customer.
- after customer insert the new hard disk he said that the stauts of Hotspare disk still occupied and did not changed to free hot spare disk.



Alarm Information
alarm:
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Handling Process
we have aksed customer to collect logs and send them to us ,after we checked the event logs we found :
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1- The fault disk is the Disk in (0,6) and customer reported error to us on 23/10/2014 and the good hard delivered was delivered to customer on 24/10/2014.
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2014-10-23 07:26:01    0x202090018    Major    None    The disk (Controller Enclosure 00, slot ID 06, ctrl ID A) response is slow.    Please replace the disk.

2014-10-23 07:26:58    0x202090018    Major    None    The disk (Controller Enclosure 00, slot ID 06, ctrl ID B) response is slow.    Please replace the disk.


2- At 24/10/2014  09:32:09  customer removed disk from slot (0,8) "which its status is normal "and insert in this slot the delivered hard disk ,then customer removed it and insert the original one.
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2014-10-24 09:32:09    0x1202090002    Infor    None    The disk (Controller Enclosure 00, slot-id:08, SN:2AVLHPSL) is removed.    Step 1 Check whether the disk needs to be replaced. If so, insert a new disk; otherwise, go to step 2.
Step 2 Check whether the slot is empty. If so, insert the disk and clear the alarm manually.

2014-10-24 09:32:09    0x201f90004    Critical    2014-10-24 09:32:10    RAID group (raid-name:RAID001) is degraded.    Disk (enclosure-id:0, slot-id:8) is faulty. Replace this disk.

2014-10-24 09:32:09    0x1201f9002c    Infor    None    RAID group (raid-id:0) reconstruction started.    None.

2014-10-24 09:32:09    0x1201f9002a    Infor    None    RAID group (raid-id:0) reconstruction succeeded.    None.

2014-10-24 09:32:35    0x1202090001    Infor    None    The disk (Controller Enclosure 00, slot-id:08, SN:6SL8246Q0000N4288EUQ) is inserted.    None.

2014-10-24 09:32:35    0x1201f90024    Infor    None    RAID group (raid-id:0) copyback started.    None.

2014-10-24 09:32:35    0x1201f90022    Infor    None    RAID group (raid-id:0) copyback succeeded.    None.

2014-10-24 09:33:01    0x1202090002    Infor    None    The disk (Controller Enclosure 00, slot-id:08, SN:6SL8246Q0000N4288EUQ) is removed.    Step 1 Check whether the disk needs to be replaced. If so, insert a new disk; otherwise, go to step 2.
Step 2 Check whether the slot is empty. If so, insert the disk and clear the alarm manually.

2014-10-24 09:33:01    0x201f90004    Critical    2014-10-24 09:33:02    RAID group (raid-name:RAID001) is degraded.    Disk (enclosure-id:0, slot-id:8) is faulty. Replace this disk.

2014-10-24 09:33:01    0x1201f9002c    Infor    None    RAID group (raid-id:0) reconstruction started.    None.

2014-10-24 09:33:02    0x1201f9002a    Infor    None    RAID group (raid-id:0) reconstruction succeeded.    None.

2014-10-24 09:33:21    0x1202090001    Infor    None    The disk (Controller Enclosure 00, slot-id:08, SN:2AVLHPSL) is inserted.    None.

2014-10-24 09:33:21    0x1201f90024    Infor    None    RAID group (raid-id:0) copyback started.    None.

2014-10-24 09:33:21    0x1201f90022    Infor    None    RAID group (raid-id:0) copyback succeeded.    None.

3- At 24/10/2014 09:33:22  customer removed the disk in (0,4) "which is not faulty" and insert the delivered hard disk.
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2014-10-24 09:33:22    0x1202090002    Infor    None    The disk (Controller Enclosure 00, slot-id:04, SN:3SL0SF1R000090484J6P) is removed.    Step 1 Check whether the disk needs to be replaced. If so, insert a new disk; otherwise, go to step 2.
Step 2 Check whether the slot is empty. If so, insert the disk and clear the alarm manually.

2014-10-24 09:33:22    0x201f90004    Critical    2014-10-24 09:33:22    RAID group (raid-name:RAID001) is degraded.    Disk (enclosure-id:0, slot-id:4) is faulty. Replace this disk.

2014-10-24 09:33:22    0x201f90009    Warning    None    RAID group (raid-name:RAID001) reconstructing failed.    Prepare a disk with a disk whose type is 1 and capacity of not lower than 543GB.

2014-10-24 09:33:22    0x1201f9002c    Infor    None    RAID group (raid-id:0) reconstruction started.    None.

2014-10-24 09:33:22    0x1201f9002a    Infor    None    RAID group (raid-id:0) reconstruction succeeded.    None.

2014-10-24 09:47:00    0x1202090003    Infor    None    The firmware version (0006) of the disk (Controller Enclosure 00, slot-id:04, SN:6SL8246Q0000N4288EUQ) needs to be upgraded.    Step 1 Upgrade the firmware version of the disk.

2014-10-24 09:47:01    0x1202090001    Infor    None    The disk (Controller Enclosure 00, slot-id:04, SN:6SL8246Q0000N4288EUQ) is inserted.    None.

2014-10-24 09:47:01    0x1201f90024    Infor    None    RAID group (raid-id:0) copyback started.    None.

2014-10-24 09:47:01    0x1201f90022    Infor    None    RAID group (raid-id:0) copyback succeeded.    None.




Root Cause
Root cause:
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- Faulty hard disk is the disk in (Controller Enclosure 00, slot-id:06) till now did not be replaced with the good hard disk ,so after this hard disk failed ,the hot spare disk replaced this faulty one and reconstruction is started and it is status become occupied.

- customer replaced the wrong hard disk.
Solution
Solution:
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1- Remove the delivered disk SN:6SL8246Q0000N4288EUQ from slot (0,4) and insert the original one SN:3SL0SF1R000090484J6P instead of it ,then wait for reconstruction to be completed .

2- Remove the faulty disk in slot (0,6) and insert the delivered hard disk SN:6SL8246Q0000N4288EUQ and wait for reconstruction to be completed the hot spare disk will be free.

Suggestions
none

END