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Appears wrong name caller from PSTN in IP phone 7910 using U1980 PBX.

Publication Date:  2014-10-31 Views:  53 Downloads:  0
Issue Description
U1980 have R2 trunk to PSTN. These U1980 have several IP phones 7910 and 7950 connected to them.
When any caller user from PSTN make a call to internal user (incoming call), sometimes appears in IP phone display the name of an internal user.
In customer site they have an AD that is synchronized with BMU.

The name of the user showed that appears in IP phone is associated with internal user with extension 10000.

7910 version: V100R001C02SPC200B011

7950 version: V100R001C02SPC200B011

U1980 version: V100R001C01SPC900

BMU version: V100R002C01SPC300
Alarm Information
None.
Handling Process
  • Analyzed logs and make sure caller user is dialing the number of correct user. But even the user 10000 appears that received a call from itself:

     
  • Check if the user that received the call with wrong name has in local contact list this user record. But didn’t have any contact list. Only appears the number of the caller in calls history.
     
  • Check in BMU the name associated with user 10000.

Root Cause
When checking the configuration of R2 trunk in U1980, we found that the DefaultCLINum is 10000:



When Caller user from PSTN didn’t provide their own number to our U1980, U1980 assign by default the number 10000 to caller number, and then BMU assign the name associated to this number.
Solution
We can assign the number 000 for avoid this issue and don’t associated with any name and number:

#config protocol cassignal officeno XX direction bidirection casname XXXX defaultclinum 000
#config protocol cassignal officeno XX direction outgoing casname XXXX defaultclinum 000
#config protocol cassignal officenoXX1 direction incoming casname XXXX defaultclinum 000


Suggestions
Need to check with PSTN provider why the caller number is not provided.
Also sometimes the caller user from PSTN not allowed that his own number being provided.

END