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eSpace U1911 reject the incoming call (QSIG trunk) from Avaya PBX

Publication Date:  2014-11-18 Views:  44 Downloads:  0
Issue Description
eSpace U1911 connected with Avaya PBX by through QSIG trunk, when extension under Avaya PBX make an incoming call to extension under our U1911, our extension no ringing and incoming call fail.

the topology is as follow.

for example: extension A make an incoming call to extension 1 or extension 2, call fails.
Alarm Information
incoming call fails.
Handling Process
  1. capture the signaling on our U1911 side. From the signaling interaction, we found our U1911 rejected the incoming call.
  2. then we checked the IE content of SETUP from Avaya PBX, and compare it with the SETUP signal that our U1911 sent.
  3. we found some defferences between Avaya SETUP and our U1911 SETUP. and we found the SETUP sent by Avaya have two "Facility" in the IE. and both PBX use seperate "User infromation layer 1 protocol---codec mode"
  4. we suggest our parter to contact Avaya Engineer to explain their parameter. 
  5. Avaya Engineer checked this issue and change the "User infromation layer 1 protocol---codec mode" from u-law to A-law.
  6. test again, and this issue solved.

Root Cause
our U1911 judged the SETUP signaling from Avaya as invalid.

After Avaya change the parameter and make it same with us. then the new SETUP signaling is as follows, and our PBX can solve it.

Solution
the peer PBX changed some parameter, then the SETUP signal change to valid, and our PBX can solve it.
Suggestions
NULL

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