No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Way to resolve NE40E static route does not take effect issue

Publication Date:  2014-12-31 Views:  61 Downloads:  0
Issue Description
Customer feedback that Friends SW12 after device replacement veneer, the core network to the RNC, the management address is not pass,
Networking is as follows:
SW12 --- Gi13 / 0/0 (NE40E) Gi13 / 0/1 --- SW13

Providing customers with nowhere addresses the following:
SW12 the following address:
116.X.Y.1
116.X.Y.2
116.X.Y.3
116.X.Y.4
116.X.Y.5
116.X.Y.6
116.X.Y.7
116.X.Y.8
116.X.Y.9
116.X.Y.10
116.X.Y.11

SW13 the following address:
116.X.Y.241
116.X.Y.242
116.X.Y.243
116.X.Y.244
116.X.Y.245
116.X.Y.246
116.X.Y.247
116.X.Y.248
116.X.Y.249
116.X.Y.250
116.X.Y.251
Handling Process
1, login the device, due to the RNC's management addresses are static routing.
There is a correlation static routing configuration on the device, but are bound with bfd
ip route-static vpn-instance 3G_IuPS 116.XY249 255.255.255.255 10.243.152.74 track bfd-session SW12_GN-DT description SW12_GN-DT
ip route-static vpn-instance 3G_IuPS 116.XY250 255.255.255.255 10.243.152.74 track bfd-session SW12_GN-DT description SW12_GN-DT
ip route-static vpn-instance 3G_IuPS 116.XY251 255.255.255.255 10.243.152.74 track bfd-session SW12_GN-DT description SW12_GN-DT
ip route-static vpn-instance 3G_IuPS 116.XY2 255.255.255.255 10.243.152.82 track bfd-session SW13_GN-DT description SW13_GN-DT
Then check the static bfd configuration is as follows:
bfd SW12_GN-DT bind peer-ip 10.243.152.74 vpn-instance 3G_IuPS interface GigabitEthernet13 / 0/0 source-ip 10.243.152.73 auto
min-tx-interval 50
min-rx-interval 50
commit
#
bfd SW13_GN-DT bind peer-ip 10.243.152.82 vpn-instance 3G_IuPS interface GigabitEthernet13 / 0/1 source-ip 10.243.152.81 auto
min-tx-interval 50
min-rx-interval 50
commit

2. make sure th route on SW12\13 does exist. Check the routing session:
<NE40E>display ip routing-table vpn-instance 3G_IuPS 116.X.Y.249
there is no route displayed;

3、Check interface and BFD sessions

Check the interface of SW12 / 13
HUNCS-YYL-NE40E-Gn-ACE1]display current-configuration interface GigabitEthernet 13/0/0
#
interface GigabitEthernet13/0/0
description TO_HUNCS-YYL_SW12_IB7-eth8_GN-DT
undo shutdown
ip binding vpn-instance 3G_IuPS
ip address 10.243.152.73 255.255.255.252
#
return
[HUNCS-YYL-NE40E-Gn-ACE1]display current-configuration interface GigabitEthernet 13/0/1
#
interface GigabitEthernet13/0/1
description TO_HUNCS-YYL_SW13_IB7-eth8_GN-DT
undo shutdown
ip binding vpn-instance 3G_IuPS
ip address 10.243.152.81 255.255.255.252
#


Check the SW bfd session:
[HUNCS-YYL-NE40E-Gn-ACE1]display bfd session peer-ip 10.243.152.74
--------------------------------------------------------------------------------
Local Remote     PeerIpAddr      State     Type        InterfaceName         
--------------------------------------------------------------------------------
8218  0          10.243.152.74   Down      S_AUTO_IF   GigabitEthernet13/0/0 
--------------------------------------------------------------------------------
     Total UP/DOWN Session Number : 0/1
[HUNCS-YYL-NE40E-Gn-ACE1]display bfd session peer-ip 10.243.152.82
--------------------------------------------------------------------------------
Local Remote     PeerIpAddr      State     Type        InterfaceName         
--------------------------------------------------------------------------------
8219  0          10.243.152.82   Down      S_AUTO_IF   GigabitEthernet13/0/1 
--------------------------------------------------------------------------------

You will find all the static bfd are in down state for DT interface of SW12 / SW13, and due to the configuration of static routes and BFD binding, so to their static route does not take effect.
Root Cause
After the SW 12 / SW13 changed the board, no static BFD configured, this lead NE40E state is down on this side, that’s why the static route bound not take effect.
Solution
After change the board, the bfd will be deleted automatically, so need to double check and apply accordingly.

END